Two appointment types (services) issue with Google Calendar

I'm having a strange issue with GCal integration. I am a homeopathic doctor and I have two services ("Initial Consultation" and "Established Client Consultation"). I'm still in the testing phase and I am having an issue where once service type syncs with GCal but the other doesn't. When I select "Established Client Consultation" under "Please select a service" on my appointment page and click "Show Available Times", it is integrating properly with the appointments already in Google Calendar. In other words, some of the times are blocked out as unavailable because there are already appointments on the calendar. However, when I choose "Initial Consultation" it shows all of the times as available. Any idea how to fix this?

Unfortunately, my site is not live on the web, unless I give you the IP address to add to your host file. My current site is hosted with one hosting company but my web designer/developer is building the new site on my new hosting account with a different hosting company. He's using the same domain but accessing the site though updating the host file.

If you need to access the site, let me know and I can give you the host file information is a private message.

Thanks.

  • Patrick

    Hey there @Ronald

    Welcome to WPMU DEV, glad to have you aboard!

    Yep, that can indeed happen if you are using the plugin's Gcal integration from the main plugin settings. This is apparently due to some limitations in what/how data can be sent from Google calendar with their API.

    So, in this type of setup, if you block off a time slot in your Google calendar and import that into the Appointments+ plugin, the blocked time is only applied to the first service in your list of services.

    To get around this, first set yourself up as a service provider for all your services. Then set "Allow Service Providers for Google Calendar API Integration" to "Yes" under the Google Calendar tab in the settings.

    You can then set up the Gcal integration from your own WP profile at .../wp-admin/profile.php

    Now, when you block off a time on your Google calendar and import it, it will block off all times for all services where you are the provider.

    Please let us know if this helps, and don't hesitate to post again if you need to.

  • Ronald

    OK. I did that, but it's still not blocking off appointments for the second service.

    Questions:
    1. I put the same information on the /wp-admin/profile.php GCal fields as I originally put in the Google Calendar tab of the plugin settings because this is the Google calendar I am using. Is this correct? Or, do I need to remove the information on the GCal settings tab of the plugin since it is the same?
    2. Do I need to remove all of the existing appointments reserved by GCal and re-sync? From what I read above, it sounds like you're saying it will work for all new appointments but maybe not for appointments that were already synced. This may be why it is not working.
    3. Is there something else I am missing?

  • Patrick

    Hi again @Ronald

    I hope you're well today!

    Indeed, it would help to remove the data from the Google Calendar tab in the main plugin settings, and rely solely on those you have entered in your own profile.

    Also, you are correct in that previously imported events from your calendar may not be affected by these changes. So to be sure things get updated, please do create new events in your Google calendar and import them.

  • Ronald

    I've removed the Google Calendar entries and I'm ready to add in the entries now. Will the entries that are reserved by GCal show up in the User Profile (wp-admin/profile.php) page? Or will they show up in the Reserved by GCal tab in the Appointments section of the plugin? Or, will they not show up at all, even though they will be recognized within the plugin and block off all times for all services where I am the provider.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.