Two WP Installations of AWS Webspace suddenly show 502 Bad Gateway

Hello Support,

this morning suddenly one of two sites on the same Amazon AWS Webspace showed "502 Bade Gateway nginx/1.4.6 (Ubuntu)", but I could still login to the Backend. I disabled all plugins except for security. Then tried to install wpmu dev dashboard, but Transmit says "folder cannot be created".

After that, I found that the style file from the Enfold Child Theme was still there but empty. Transmit says that file cannot be updated, writing error. Strangely suddenly there are some more files in the child theme called e.g. "style_safe_save_095042.css".

After that, the other WP site on the webspace began showing the same symptoms.

Do you have any idea what could be happening there? Is someone hacking the sites perhaps?

Thanks for your help,
best,
Julian

  • Rupok
    • Support Ninja

    Hi Julian,

    So sorry to hear the inconvenience you are having. This is really weird. We can't remove the chances of your instance being compromised. But before trying anything, can you please talk to your host regarding this? If there is any abnormal entry in the server access log, that will give us more idea regarding this issue.

    Now as you can't install any plugin through FTP, can you still give it a try to install through the WordPress Dashboard > Plugins > Add New section? If you can install the Dashboard plugin, can you please install our Defender plugin and scan your site with Defender?

    If you can't install any plugins in any way, can you try fixing your WordPress files and folder permission according to the suggestions of this official codex page? https://codex.wordpress.org/Changing_File_Permissions

    I believe that will allow you to install our Defender plugin.

    If nothing works, then I'll suggest you to take a backup of your files and database and then restore that backup on your local server and try to fix the issues first. When issues are fixed, you can then upload the fixed setup to your server again. To know how you can create a local server, you can check these guides:
    Windows: https://premium.wpmudev.org/blog/setting-up-xampp/
    Mac: http://www.wpbeginner.com/wp-tutorials/how-to-install-wordpress-locally-on-mac-using-mamp/
    Linux: https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-with-lamp-on-ubuntu-16-04

    I believe, these will help. Please let us know if you have any confusion or any further query. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Julian Wiprich
    • New Recruit

    Hi Rupok,

    thanks for your amazingly detailed answer! I tried a few of the things you suggested. However, things were getting ever stranger - and at one point I had no ftp-rights anymore, so I couldn't install the plugin.

    However, now the problem is solved. It was simply the AWS webspace running out of webspace. I don't manage the webspace, so I had to wait for someone to fix it: They made more space, and now things are functioning again (except for my CSS which was deleted, but luckily I had a backup).

    Again, thanks for your help,
    and all the best,
    Julian

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.