TYPING IN yoursite.com.au/questions/ask GOES NO WHERE

Can someone please advise how to get this to show.

I have set the settings but typing in

Usage docs say to Visit http://yoursite.com/questions/ask/ to create your first question.

BUT YOU CANT GET TO THAT PAGE!

How do you get it to appear in the menu so you can allocate it?

Or it is in Buddypress somewhere??

It is NOT CLEAR in the usage documents how to SET IT UP and FIND THE PAGES!

Please advise.

  • Karen

    Ari

    Thanks for that. Unfortunately it doesn't help as it doesn't address the issue that is happening.

    FYI I am familiar with menus (I have a main one and a secondary one in place.)

    I am confused as every other plug in produces its own pages - so I presumed this plugin does the same. Doesn't it?

    If that is not the case, then perhaps the usage documents should make that clear.

    Usually the created page appears in the menu list so you can add it to the menu. But this questions/ask page didn't - so my question was "Where is it?"

    The Usage documents says:
    "Simply install and activate the plugin, visit yoursite.com/questions/ask/ and start asking questions!"

    The problem is - that is not working. I installed the plugin and typed in https://www.publicaffairsjobs.com.au/questions/ask and NOTHING appears. It just takes you to the About Us page.

    In Q&A Settings there isn't anywhere to nominate which is the Q&A page or where to send people (eg About Us) so I am not sure why there isn't a /questions/ask page appearing as the Usage docs note.

    Is there an instruction step missing?????? It seems like it.

    If I have to create the page and add it to the menu - then the usage instructions should tell you to do that.

    Please advise how to get that page to appear.

    1. Do I just create the questions/ask page?
    2. Do I use shortcodes?

    ie HOW do you make the plugin work as the "Just..." does not work.

    Also WHERE do the points appear for a particular person? In their BuddyPress dropdown list? That isn't clear either.

    Thanks.

    regards,
    Karen

  • aristath

    I am confused as every other plug in produces its own pages - so I presumed this plugin does the same. Doesn't it?

    No, it does not. It uses virtual pages.

    The problem is - that is not working. I installed the plugin and typed in https://www.publicaffairsjobs.com.au/questions/ask and NOTHING appears. It just takes you to the About Us page.

    Could you please try resetting your WordPress permalinks?
    To do so, from your dashboard go to Settings => Permalinks.
    Make sure you've selected pretty permalinks (such as postname) and then hit save.
    When you save the permalinks, WordPress is forced to re-generate all permalinks and hopefully resolve this issue.

    If I have to create the page and add it to the menu - then the usage instructions should tell you to do that.

    No, you should not cr5eate a page. You should simply add a new custom menu item if you want to have this item in your menus.

    1. Do I just create the questions/ask page?
    2. Do I use shortcodes?

    You shouldn't have to do any of that.

    Please let me know if that works for you!

    Cheers,
    Ari.

  • Karen

    Ari

    Thanks for the response.

    Just did that (I have selected https://www.publicaffairsjobs.com.au/2014/04/25/sample-post/ as the normal way of naming pages FYI)

    Nope - it is still taking me to the About Us page.

    Are you able to get access to my site to check?

    Support access is ACTIVE until April 28, 2014 4:12 pm

    ***

    FYI Before I saw your answer I created a page called questions (now qapage) so I could advise people of the rating system. Do I remove this?

    Post Your Questions Here!

    Feel free to ask us any questions you might have.
    You'd Like to Answer the Questions?

    If you would like to provide answers and gain an industry rating as an expert, here are the points that are awarded automatically once an action qualifies:
    Reputation points

    Reputation points are set at the following values by default:

    Having an answer accepted: 15
    Accepting an answer: 2
    Having an Answer voted up: 10
    Having a Question voted up: 5
    Penalties:

    Having a Question voted down: -2
    Voting a Question or Answer down: -1

  • Jack Kitterhing

    Hi there @Karen,

    Hope you're well today and thanks for the additional information.

    I'm afraid the support access has expired, but I believe I know what's happening here.

    The plugin automatically creates the /questions/ask page.

    By default in the Q&A settings, you define which page a user gets redirected to if they don't have permission to ask a question, I believe this is set to "About Us", can you check that please?

    Then also in questions > settings, capabilities, make sure each role has the capabilities setup as you need.

    Thanks!

    Kind Regards
    Jack.

  • Karen

    Jack

    Thanks for the answers. (PLEASE have someone look at the Usage documentation as NONE of this hassle is clear to the reader.)

    The plugin automatically creates the /questions/ask page

    If that is the case then WHY when I type in my /questions/ask page is it redirecting to About Us page. (see USAGE docs which do NOT tell you that the set up of each category of user determines what is seen).

    By default in the Q&A settings, you define which page a user gets redirected to if they don't have permission to ask a question, I believe this is set to "About Us", can you check that please?

    yes, it is set to About Us...but I am an administrator and I am getting sent to the About Us page.

    ***

    I have only set a QA visitor who can:
    View questions
    Ask questions
    Immediately publish questions and answers
    View answers
    Add answers

    ***

    OK Now I have set myself up as Administrator (see all) and have QA visitor as above and Subscriber (which I presume is the Membership Subscriber (actually WHAT does Subscriber relate to? What sort of Subscriber. If you have Membership installed you have a lot of different subscribers - for some reason my list has Shop Manager and other irrelevant titles in it. Are we supposed to set the list up somehow/somewhere?)

    I can now add a question AND answer it - but it still isn't clear where it is appearing on the site and how anyone will find it.

    1. HOW do they get to it? Where does it show up? Which part of the site and ONLY to the people listed (Admin, QA visitor, Subscriber?).

    https://www.publicaffairsjobs.com.au/questions/test-question-1/#answer-2482 is where my test Q&A is turning up...but apart from me knowing that - HOW do you FIND the LIST of QUESTIONS people have asked? It is REALLY UNCLEAR.

    2. HOW (and WHERE on the site) do you get to tell them about the points system?

    I created this https://www.publicaffairsjobs.com.au/qapage/ but HOW do you LINK it to the Questions / Answers Pages? (again VERY UNCLEAR).

    3. Are you supposed to somehow get the Q&A pages in the menu. If NOT, HOW does ANYONE know they are there?

    This experience is NOTHING LIKE the USAGE documents say. It is NOT SIMPLE to setup or USE.

    Help please.

  • Jack Kitterhing

    Hi there Karen,

    Hope you're well today :slight_smile:

    OK Now I have set myself up as Administrator (see all) and have QA visitor as above and Subscriber (which I presume is the Membership Subscriber (actually WHAT does Subscriber relate to? What sort of Subscriber. If you have Membership installed you have a lot of different subscribers - for some reason my list has Shop Manager and other irrelevant titles in it. Are we supposed to set the list up somehow/somewhere?)

    The subscriber is a default WordPress user role, other default WordPress user roles are editor, author, Administrator. These all have different capabilities of what the user can and can't see and plugins use these roles to determine what someone can see.

    I believe that the Shop Manager role is one created by WooCommerce.

    1: You'd need to add a link to your menu, in appearance > menus, do you already have a custom menu set? If you do click "Links" and type in http://yourdomain.com/questions

    This is the main Q&A page where the list of questions can be found that have been asked, and all the other links are such as ask a question etc.

    2: The points system at the moment, you would need to put that on a page of your choosing and then add a link to yourdomain.com/questions on it.

    3: See number one above :slight_smile:

    For changing the color, you can use the following CSS.

    #container .content a {
        color: #FFFFFF !important;
    }

    You can add that using something such as https://wordpress.org/plugins/simple-custom-css/

    Thanks!

    Kind Regards
    Jack.

  • Karen

    Jack

    1: You'd need to add a link to your menu, in appearance > menus, do you already have a custom menu set?

    I have two menus - one main one and another one.

    BUT

    If you do click "Links" and type in http://yourdomain.com/questions

    when I go to menus there is no "Links on the page".
    Also in the http://yourdomain.com/questions - shouldn't the www. appear?
    (I also have https: site. FYI.)

    Feel free to have a look but it isn't there on my theme (BP Fun).

    ***
    OK I got it sorted.

    I DIDN'T use the menu instructions.

    I used my page:https://www.publicaffairsjobs.com.au/qapage/ as per your answer to my Q2.

    2: The points system at the moment, you would need to put that on a page of your choosing and then add a link to yourdomain.com/questions on it.

    I then added a Ask a Question in the body text and linked it to the /questions page.

    NOTE: The MANUAL people need to know about this. Please let them know so they can update the documentation and make it MUCH clearer than it currently is.

    Thanks.

    PS Text is still blue not white. Please revisit and advise. Thanks!

  • Jack Kitterhing

    Hi there Karen,

    Hope you're well today :slight_smile:

    The docs team is currently working on getting everything updated and more user friendly :slight_smile:

    For the css, try this instead, rather than change the link color, the changes the background color, as changing the link color, seemed to effect the question links as well.

    #qa-menu li {
        background-color: #FFFFFF !important;
    }

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.