Ultimate Branding FavIcons failing?

We use Ultimate Branding to maintain various favicons for our subsites on two different WP instances (one IIS, one Apache/Linux). We just noticed that after the latest WP core update, the site favicons have now been replaced by the default WP icon.

I went into the Apache/Linux WP admin and tried various settings within Ultimate Branding's Images tab, but nothing is working to correct the issue. When I paste a path to a PNG image in the field for one of the subsites and click the row's Save button, it appears to save and the icon thumbnail is correct. But refreshing the page shows our own branded icon in the thumbnail column again (despite the correct path showing). If I click the Save Settings button at the bottom of the Images page, it reverts the path to our default branded icon's path as well.

And despite all this, even though our default icon appears within Ultimate Branding's Images settings, it is not used as the favicon for any of our sites on the front-end. They all have been reverted to WP's default.

I also tried toggling the setting for allowing overwriting the icon from Appearance > Customize, but it made no difference.

Thanks,

Josef

  • Vaughan

    Hi Josef,

    Hope you're well?

    This is a known bug and has been fixed in the development branch, however, it's not ready for release yet.

    You can try the following patch which I have attached to this post.

    Download the attached zip & unzip it to your desktop.

    Now, using FTP, upload the enclosed favicons.php file to the following location.

    /wp-content/plugins/ultimate-branding/ultimate-branding-files/modules/favicon.php

    Hopefully, that should fix this issue for you.

    Regards

  • Josef Cook

    Just following up on this old ticket to see if the aforementioned favicons.php replacement workaround has been released into the newest version of the plugin yet?

    I am currently running version 1.9.3, and just attempted (Sunday, 11/26/17) to implement a sub-site favicon through the plugin, but only met with failure.

    On Sunday I added enabled the Favicons feature (it had been disabled since around the time of this ticket's creation). Through the plugin, I uploaded a favicon for a subsite and clicked the row Save button. Cleared caches in W3TC. Favicon displayed correctly in the plugin's list, but did not appear when visiting the site.

    I selected the option to allow the plugin to override any favicon from the subsite's customizer (there was nothing entered there anyway). It still would not appear after clearing caches.

    I disabled the Favicon feature, went to the site's customizer and added the favicon there. Cleared caches and it appeared immediately in the frontend.

    I would like to use this feature, since I maintain over 30 customer sites in my network, but I can't seem to make it work. Any assistance or guidance would be appreciated.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.