Ultimate Branding- got the white screen of death

I did run into one problem with Ultimate Branding. I tried to enable all branding features and got the white screen of death. Went into the server and moved the folder out of plugins to cure the white screen. Then I went ahead and put it back in. No white screen, good. When I try to put it back into plugins folder now, instant white screen of death. So... if you could tell me where to look in the db for entries/rows to delete/drop so that it will reset it to being like a newly installed plugin, I'll give it another whirl. I didn't see anything that looked obvious, wp_ub------etc

  • John Paulding

    Started fresh with my network due to corrupt database. Rebuilding the site from scratch and still have a problem with Ultimate Branding - white screen of death. At this point I've thoroughly narrowed it down by deactivating all other plugins, swapping to 2014 theme and disabling all branding features. I re-enabled one feature and get white screen of death - Admin Help Content is the culprit.

  • Sohag Ronjon Dey

    Hi John Paulding,

    How are you doing today!

    Sorry to hear that you are having some inconvenience. Please add the attached code in your active themes functions.php file. Before that have a backup of your entire site's database this will prevent you from losing everything if something goes wrong. Then open the site in the browser and you will find all the ultimate branding settings will be gone. Now remove the code that you added and try installing and recofiguring the plugin.

    Suppose you have activated the Twenty Fourteen theme then you will find the functions.php file in twentyfourteen directory like

    main wordpress directory
    |--wp-admin
    |--wp-includes
    |--wp-content
    |    |--plugins
    |    |--themes
    |    |    |--twentyfourteen
    |    |    |   |--functions.php

    If you like and allow then we can do this for you for this please take your database backup and send us your details through our contact form so I can try to investigate this further,

    https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Sohag"
    -WordPress admin username
    -WordPress admin password
    -login url
    -ftp credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me

    Please DO NOT post the credentials here as this is a public forum, also would you mind me doing some basic troubleshooting such as temporary deactivating all plugins?

    Please let me know.

    Cheers,
    Sohag

  • John Paulding

    As per my previous post I found the cause. It's "Admin Help Content". As long as I leave that disabled, I'm fine.

    I tried adding your code to my active theme's functions.php. It did clear the setting but as soon as I try to activate the Admin Help Content feature I get the white screen. I've tried deactivating all other plugins and changing themes. With only wpmu dev and ultimate branding activated and only enabling Admin Help Content, I get white screen.

  • Sohag Ronjon Dey

    Hi John Paulding,

    Thanks for the reply and I hope you are having a beautiful day!

    Happy to hear that the code is worked in removing the settings. The settings are stored in the options table but it will not be a better idea to remove plugin settings manually as that can be dangers and will lead to loss of settings in other parts.

    Now the settings are clear and I can re-install and start over (ya thanks for that) btdt, but I still won't be able to enable Admin Help Content

    Nope, not working - Now I have no ultimate branding at all. Could you just tell me what table in the datatase the UB settings are stored?

    Please make sure that you have removed the code from the functions.php. Otherwise it will not let you save any settings as it is intended to remove them.

    If you still have the issue after removing the code then will you please grant support access and send us your ftp credentials so we can take a closer look at your end?

    You can grant support access via

    Dashboard - WPMU DEV -> Support -> Support Access -> Grant Access or

    by following this guide here:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please send us your ftp cridentials through our contact form,

    https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Sohag"
    -WordPress admin username
    -WordPress admin password
    -login url
    -ftp credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me

    Please DO NOT post the credentials here as this is a public forum, also would you mind me doing some basic troubleshooting such as temporary deactivating all plugins?

    Let me know when you do so!

    Cheers,
    Sohag

  • John Paulding

    btw - you should read this thread - then you would see; From Wed May 17th.

    At this point I've thoroughly narrowed it down by deactivating all other plugins, swapping to 2014 theme and disabling all branding features. I re-enabled one feature and get white screen of death - Admin Help Content is the culprit.

    So I already tried Wed what you asked me to do yesterday. I'm not giving out cpanel info to support staff member who can't or won't read the entire support thread.

  • Sohag Ronjon Dey

    Hi John Paulding,

    Thanks for the prompt reply!

    I am really very sorry if I made you feel any inconvenience. Please accept my apology. I have tried to regenerate the issue in my end again and also asked another support colleague to test on her end but we could not replicate it. It could still be a bug on our end and just only shows up in your environment. In this situation we would recommend you to enable debug mode in your site which will log the errors in a file in your site's backend and will help us to have a better idea.

    To enable debug mode, open your wp-config.php file located in your root directory, and look for

    define( 'WP_DEBUG', false );

    replace it with:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Please make sure this code ends above the "/* That's all, stop editing.... */" line.

    This will log the errors and prevent to show the errors on the front end.

    Once done please try to regenerate the issue again and when the issue occurs, find the debug.log file at /wp-content folder and send us the debug log (you can remove all the URL information before the plugin name in individual warnings for privacy) and if possible also send us the server logs. Maybe this will help identify the issue.

    I will look forward to hearing from you.

    Cheers,
    Sohag