Ultimate Branding not accepting png favicon.

I am curious if any others have experienced the same issue I am experiencing. I am running WP 3.4. with Ultimate Branding v1.0.3.

When I upload a png favicon, it says "Changes Saved" but under the favicon settings it shows "none set."

When I upload a gif, I receive the success message, and it is applied to the site. (Unfortunately, my gif version does not look that great.)

As far as I can tell, there is nothing wrong with my png file, and I have successfully used it on another site by manually applying it.

Has this occurred to others?

Also, I am surprised that we cannot upload iso files as favicons. Any reason for this?

  • 3SixtyEvolve

    Hi @nicmitchell

    Thank you for your post and being a member of our Community!

    As per the guidelines:

    Image must be 500KB maximum. It will be cropped to 16px wide and 16px tall. For best results use an image of this size. Allowed Formats: jpeg, gif, and png

    Note that gif animations will not be preserved.

    If you upload an image that doesn't comply with these guidelines you will get the message 'None set'. If however, you upload as per the guidelines, you will see the image appearing.

    Currently the Ultimate Branding plugin doesn't allow for icons (.ico) to be uploaded, but this is definitely something that can be added as a feature. I will let the Developer know of this.

    All the best!

    Gina

  • Barry

    Currently the Ultimate Branding plugin doesn't allow for icons (.ico) to be uploaded, but this is definitely something that can be added as a feature.

    The main reason is that Wordpress limits the extensions that can be uploaded, and I dont think .ico is one that is included as default - as Ultimate branding uses the WP upload functions, these restrictions are in place as well. If you have allowed ico files to be uploaded, then Ultimate branding should upload them as well.

    As far as I can tell, there is nothing wrong with my png file, and I have successfully used it on another site by manually applying it.

    What version of the GD image library do you have on your server? If I recall, earlier versions had issues with resizing PNG images with transparent pixels.

  • Barry

    That's a good question and I have no idea. However, the image was the correct size upon uploading, so I don't think that should matter.

    The older GD libraries used to go wrong if a png had a transparent pixel in there - I remember spending hours / days debugging this a while ago and then finding out my host had an older / buggy version of the library - most hosts should have newer versions by now, but you never know :slight_smile:

    However, I did want to give an update that I changed the allowed upload extensions in the network admin to include.ico, and I was able to successfully upload the original favicon.

    Excellent news :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.