Ultimate Facebook commenting not removing WP comments from GridMarket Theme

On my client's site, http://africashamanexperience.com/, I'm using the Facebook comments system and have chosen to use it instead of the WordPress (yes, I HAVE clicked the box that says, "If checked, Facebook comments will be used instead of, or in addition to, regular WordPress comments.")

But as you can see from any of the blog posts at:
http://africashamanexperience.com/category/module-1

Both the WordPress and Facebook comments are appearing.

Any ideas?
Thanks
Haroun

  • 3SixtyEvolve

    Hi Haroun

    Hope you're well.

    This might be able to assist:

    Remove comments from WordPress

    Now if you would like to follow the route of editing the code that relates to comments, you'll need to find and edit your theme files. This is an alternative method, and one that I personally prefer doing. With this option comments code will still appear in the WordPress admin but, with theme files, it's possible to disable them from appearing anywhere on your website. Just remove the comment reference from your code.

    There are two files in which comments commonly appear: the single.php which is used for blog posts and page.php which is used when a page is displayed. If you're using a more modern theme, you may have a loop.php file which is called by each of these files and will contain the reference instead. Opening each of these files will reveal a piece of code similar to <?php comments_template( '', true ); ?> which, if removed, will stop WordPress from calling the comments for all pages and posts. Or simply replace 'true' with 'false'. Other files where comments code might be found:

    - archive.php
    - comments.php
    - index.php

    Look for code like this:

    <?php if ('open' == $post-> comment_status) : ?> ... <?php endif; ?>

    For example:

    <?php comments_popup_link('Leave a Comment', '1 Comment', '% Comments'); ?>

    Would be replaced with:

    <?php if ('open' == $post-> comment_status) : ?> | <?php comments_popup_link('Leave a Comment', '1 Comment', '% Comments'); ?><?php endif; ?>

    I hope this helps. I believe you're using the GridMarket Theme, so the best option would be to make a copy of it in the wp-content/themes folder and rename it to gridmarket-no-comments, in case you have to upgrade the theme at some point, you won't be overriding these changes.

    Hope this helps :slight_smile: Have a good weekend.

    Gina

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.