Ultimate Facebook Connect Not Working

I installed "Ultimate Facebook" in the latest Version 2.7.7 and it's not working. Specifically it's not showing the "login" button when activating the connect feature!

Here's the site...
http://sharpstory.net

I have tried disabling all plugins and reverting to the default theme... nothing works.

It's connecting to the API successfully.

I'm using The Frog Theme:
http://themeforest.net/item/the-frog-creative-newsblog-magazine-wp-theme/9121141

I've tried using the widget (which did not appear at all) and the shortcodes in a text widget (where it did not recognize some shortcodes)

Please help me fix that immediate!
Best,
Melvin

  • Michael Bissett

    Hey @Upside, hope you're doing well today, welcome to the WPMU DEV Community! :slight_smile:

    It'd help if we could have a closer look at your settings here, could you please enable Support Access for your site?

    Alternatively, could you please send in the following:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Upside,

    After having a closer look at Facebook -> Facebook Settings -> Facebook Connect, I noticed that the box for "Allow users to register with Facebook" wasn't checked. After checking that box (see screenshot), I was able to get the login button (as well as the shortcode) to show up. :slight_smile:

    However, in the process of testing, when I tried logging in via Facebook, I got this error:

    Given URL is not allowed by the Application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.

    Could you post a screenshot of your Facebook app settings please, so that we can have a closer look at that? (if you'd rather send it over via email, you can send it over the same way I laid out for sending over the login details in my previous post) :slight_smile:

    Thanks a bunch! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Upside,

    For some reason, a Facebook app ID, different from the one that you've set inside of Ultimate Facebook, is being used on that Facebook Connect button on the front end.

    However, when trying to log in via wp-admin, I'm finding that the Facebook Connect button works properly there.

    I've called in our second line support staff on this one, to try to get their input on the matter. One of them should be along soon.

    Hope you're doing well! :slight_smile:

    Kind Regards,
    Michael

  • Jose

    Hi there @Upside,

    The FB login is working now. :slight_smile:

    The issue was caused by a conflict with other plugins:
    - SEO plugin was adding some og tags. I disabled the Open Graph Integrator.
    - You are using also the 'Facebook' plugin in your site. It was configured using a different Application ID. I changed it to use the correct ID.

    I'm not sure if yoou are actualy using some feature from the 'Facebook' plugin. I would suggest to keep just a single plugin for FB integration.

    Please let me know if everything works as expected.

    Cheers,
    Jose

  • Upside

    Thank you Jose!

    Indeed, the plugin worked but after I deactivated the 'Facebook' plugin (because - you're right - we won't need it and it caused the comments to show twice on the page) I was not able to Facebook connect again.

    Attached you'll find error messages on Chrome and Internet Explorer (they are different for some reason!?).

    For us it's crucial to have the Ultimate SEO Plugin active. We did some individual coding when importing the new stories into the blog. That's why we need this plugin.

    I would be happy to get this working today!
    Best,
    Melvin

  • Upside

    Thank you Jose!

    Indeed, the plugin worked but after I deactivated the 'Facebook' plugin (because - you're right - we won't need it and it caused the comments to show twice on the page) I was not able to Facebook connect again.

    Attached you'll find error messages on Chrome and Internet Explorer (they are different for some reason!?).

    For us it's crucial to have the Ultimate SEO Plugin active. We did some individual coding when importing the new stories into the blog. That's why we need this plugin.

    I would be happy to get this working today!
    Best,
    Melvin

  • Michael Bissett

    Hey @Upside,

    Attached you'll find error messages on Chrome and Internet Explorer (they are different for some reason!?).

    In the first screenshot, you were already logged into Facebook, whereas in the second screenshot you were logged out of Facebook. That's why they were different. :slight_smile:

    Indeed, the plugin worked but after I deactivated the 'Facebook' plugin (because - you're right - we won't need it and it caused the comments to show twice on the page) I was not able to Facebook connect again.

    For some reason, I'm seeing that the incorrect App ID is being referenced when I try using Facebook Connect (even though I can't find that ID entered anywhere inside of your WordPress site).

    It seems like this is going to require some deeper digging, could you please send in the following:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details
    - Include FTP log-in details
    - Include cPanel details (will need phpMyAdmin, in order to look at the database)
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks a bunch! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Upside, thanks for your patience here! :slight_smile:

    After doing some further investigation, it turns out the reason you were getting those error messages was actually due to the header.php inside of your theme.

    There was some JavaScript code at the bottom of the file that was setting the Facebook App ID, and that's what was being sent to Facebook when a user tried to use Facebook Connect to log in on the front end.

    I've taken care of removing that code for you, and can confirm that the Facebook Connect button is working properly on my end. Could you confirm that it's working properly on your end as well? :slight_smile:

    Hope you had a great weekend, looking forward to your response here!

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.