ultimate facebook doesn't accept app details

it says Please, enter correct Facebook API settings. I've read the app guide to create the app and it says the plugin should have a checkbox if I'm using another plugin with the app details, but there's no check box. please help.