Ultimate Facebook (Facebook Connect button) breaks BP-Corporate User login from homepage.

When I have the Ultimate Facebook plugin active, the Facebook Connect button's <p> tag forces the User Login on a BP -Corporate Theme homepage to look funny (pushed login downwards and button does not appear). How can I correct this?

  • Vaughan
    • Support/SLS MockingJay

    hiya

    can I ask how you implemented the FB connect button in your theme?
    I'm unsure as yet why the button doesn't actually appear.

    as for the positioning issue.

    if you add

    .wdfb_login_button {
    
    }

    to your themes style.css (adding the values you need inside, you should be able to position the button where you want. it's hard to guess the position till we can get the button image actually appearing though.

    but it appears inside the div id="fc_wrap" element, which is what's throwing the login form down, because the actual FB button placement appears above the form. we just can't see it because the button isn't actually displaying any image.

    hope this helps

    thanks

  • epicyes
    • WPMU DEV Initiate

    1. Activated WPMU's Corporate theme (with the child theme)
    2. Activated WPMU's Ultimate Facebook plugin
    3. Setup WPMU's Ultimate Facebook plugin to connect with Facebook's API (as I've done previously).
    4. Checked the first box in the WPMU Ultimate Facebook plugin to use Facebook Connect.
    5. Went to the homepage of beta.earthwire.com

    If you Firebug the homepage, the code for the Facebook connect button is there, but does not display. Because of the button's <P> tags, it's also pushing the built in user login down a line on the screen, out of the default silver bar...so it's not aligned with the default search box on the left side of the page. And there's no option to just shut the facebook login on the home page and replace it with a widget facebook login.

  • Vaughan
    • Support/SLS MockingJay

    hiya

    i just installed, WPMU Corporate theme. I get the exact same problem as you have.

    it's fine on other themes that i've tested with. the button just doesn't want to appear, but the placeholder does.

    This doesn't appear to be an issue with the plugin itself, but more related to the actual theme. I'll ping @Vladislav (plugin dev) & @Jeffri (theme dev) for some feedback.

    hopefully they should be able to fix this in no time.

    thanks

  • Vladislav
    • Dead Eye Dev

    Hello,

    This appears to be a styling issue, and solving it depends on whether you want to show the button, or to remove it entirely and have it not break the layout. To show the button properly, there are a few hoops to jump through as we have to make some room for it too. Something like this should work though:

    <style type="text/css">
    #fc_wrap p.wdfb_login_button {
    float: left;
    width: 160px;
    margin: 0; padding: 4px 0 0 0;
    }
    #fc_wrap p.wdfb_login_button .fb_iframe_widget {
    display: block;
    position: static;
    }
    #fc_wrap p.wdfb_login_button span {
    display: block !important;
    height: auto !important;
    width: auto !important;
    }
    #searchbox #search-form {
    width: 320px;
    }
    #container #search-form #search-terms {
    max-width: 120px;
    }
    </style>

    To simply remove it and have it not break the layout, the solution is much simpler:

    <style type="text/css">
    #container #fc_wrap p.wdfb_login_button {
    display: none;
    }
    </style>

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.