Ultimate Facebook Install Queries

My end goal is to have any post from anybody on the FB page to auto copy to the sidebar on website blog page (news). I hope I can display the last "x" posts with option to scroll to earlier ones.

By the way, if a post is deleted on FB is it auto deleted on website?

I have input the API keys but I don't know which settings to configure. The WPMUDEV guide referred to is a series of .png that are not showing up on my screen when I click the links.

  • Michael Bissett

    Hey @Freebird, Michael here! :slight_smile:

    My end goal is to have any post from anybody on the FB page to auto copy to the sidebar on website blog page (news).

    Ultimate Facebook will import comments from posts shared on Facebook back into your blog, but it'll import them as WordPress comments, rather than posts.

    So if you're wanting to display the latest comments for posts, and have those imported Facebook comments come up, then that can be done, but comments would not be imported as WordPress posts.

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Freebird, sure thing! :slight_smile:

    Before we begin, you'll want to make sure that you've granted extended permissions. Inside your site's Dashboard, you'll want to go to:

    Facebook -> Facebook Settings

    And check out the "Permissions & Tokens" section. If you see "You already granted extended permissions" there, you're all set here. If not, you'll want to click on the "Grant extended permissions" link presented in that section.

    With that settled:

    I need help with getting posts to go to Facebook...

    Down at the bottom of the Facebook Settings page, you'll want to go to the "Autopost to Facebook" section.

    When you're there:

    - Check the box for "Allow autoposting new posts to Facebook".
    - In "Map WordPress types to Facebook locations", be sure to set "Autopost Posts to" to your Facebook Wall, and to set "of this user" to the profile/page you're wanting to post to.

    Save the changes, and you're good here!

    Now, as for this:

    ...and comments to come back as WP comments.

    In the "Facebook Comments" section on the Facebook Settings page, you'll want to have the "Import Facebook comments" checked, that's what'll enable your Facebook comments to be imported.

    Hope this helps! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Freebird, my apologies for the delay here!

    I want the posts to go onto the Page of facebook.com/drentonandsonsalnwick nad not my personal page, but the only option I get in the dropdown is "Me".

    Are you an admin of the page that you mentioned? That's a pretty important requirement.

    Also, I noticed that from your screenshot, the extended permissions hadn't been granted, could you please do that?

    On that notice you got in the popup, what's the API version of your app? Is it 2.0, or a different version?

    Please advise,
    Michael

  • Freebird

    Hi

    Yes, I am an admin on the facebook page.

    Extended permissions were already set under the permissions tab, and confirmed, but I still got the message you see on the screenshot, despite this. When I click on the link shown in the screenshot, I get the pop up saying that Facebook does not approve some permissions. At this point I don't know how to continue. I assume I have some configuration wrong somewhere in the process but I don't know where.

    The API is v2.5

    It would be great if we could resolve today as we had planned to launch client site over the weekend and this is the only outstanding item. Thanks,

  • Michael Bissett

    Hey @Freebird,

    Seeing as this is the outstanding item, could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    I'll send in the email address & username for my Facebook account via email, as I'll need you to add me as an admin for your page (temporarily, of course), as I'm still finding myself unable to reproduce the behavior you mentioned.

    I'll be keeping a special eye out, so that I don't miss your response.

    Thanks in advance, looking forward to getting this resolved for you! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Freebird, thanks for doing that! :slight_smile:

    Okay, after digging into this quick, several things needed to be adjusted:

    #1: Your site's address had to be added to the "App Domains" section inside of:

    Settings -> Basic

    #2: Your site's address had to be added to the "Valid OAuth redirect URIs" field inside of:

    Settings -> Advanced

    #3: A contact email had to be specified inside of:

    Settings -> Basic

    I set it to the email address you contacted us with, but you can change it to a different address, if you wish. :slight_smile:

    #4: The app itself needed to be publicly available, via the "Do you want to make this app and all its live features available to the general public?" setting inside of:

    Status & Review -> Status

    After doing all that, and with a quick check of one of your existing WordPress posts, I'm now seeing that your page is coming up on my end, as being available to choose as a place on Facebook to publish the post to.

    Could you check from your end now, and see if you're able to publish to your page? You may need to re-grant the extended permissions for your user as you do this.

    Please advise,
    Michael

  • Michael Bissett

    Hey @Freebird, following up from your email here:

    Thanks for the update, very useful. However I am still having problems.
    When I publish a post I do not see it appear on the business Facebook page.

    The error log suggests I don't have permission.

    The settings within WPMUDEV plugin state "extended permissions already granted"

    Could you try going to your App Settings in Facebook:

    https://www.facebook.com/settings?tab=applications

    And remove your app from the list of authorized apps by clicking on the "x" for it? (you may need to first click on the "Show All" link further down the page if you're not seeing it come up in the list)

    Then, inside of your WordPress site, you'll want to go to:

    Facebook -> Facebook Settings

    And click on the "Permissions & Tokens" tab, afterwards clicking on the "Grant extended permissions" link in that section.

    Now, in the login popup presented by Facebook, ensure that when you reach this prompt:

    [name of app here] would like to post to Facebook for you.
    Who do you want to share these posts with?

    That the dropdown menu is not set to "Only Me". I'd set it to Public.

    Then, once you've done that, you'll want to go to the "Autopost to Facebook" section, and ensure:

    - "Autopost Posts to" is set to "Facebook Wall".
    - "of this user:" is set to "D Renton & Sons - Alnwick Ltd".
    - "If posting to a page, post AS page" is checked.

    Once you do that, and post a new post, you should see it posted on your page. I did all that, and found that my test post was posted over there (I've removed it shortly afterwards).

    Let me know if this helps please! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Freebird,

    Got another email from you, let's continue the discussion here, rather than via email:

    1. After a website generated post appears on FB, I commented on that post as the FB page. Nothing appeared on the website.

    2. My user commented on FB, as himself, nothing appears on the website.

    The syncing of comments from Facebook is done via cron job on an hourly basis (of course, WordPress's cron system requires traffic to the website, so if there isn't any traffic, that'll affect the frequency).

    You can of course manually force the syncing of comments, via the "Import comments now (this can take a while)" link in the "Facebook Comments" tab.

    3. If I update a previously published post on the website this update is not reflected on FB. If I choose the option to have an updated website post appear on FB under a new title, nothing happens.

    In order to have changes to a post be reflected, or to have a post come up with a new title, you'll need to ensure that the "wdfb_published_on_fb" entry in the "Custom Fields" metabox is changed from 1 to 0.

    You'll need to save the post inside of WordPress after doing this, and then you'll need to save it again (after making the desired changes, of course) in order for it to be re-posted to Facebook.

    You'll need to delete the old post in Facebook, as this method will create a new Facebook post, rather than updating the one that's already there.

    4. No comments made on the website appear on FB.

    WordPress comments posted would stay on your site, and Facebook comments would be displayed on your site by default (a user can post a comment to his own wall, though, if he checks the box for "Also post on Facebook" in the process of posting his comment).

    You'd be welcome to open a feature request for comments posted from the website to be posted on an article shared via Ultimate Facebook, though I would like to caution that Facebook's API may very well not allow us to do so:

    https://premium.wpmudev.org/forums/forum/feature-suggestions#question-modal

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.