Ultimate Facebook Plugin not working

Hi,

I’ve installed the plugin, added my App ID and Secret from Facebook and have configured the other settings.

However, all that’s appearing in my source code is:

<div class="wdfb_like_button"><fb:like href="http://smokefreediary.com/about/" send="true" layout="standard" width="300" show_faces="true" font=""></fb:like></div>

No Like button at all.

The code can be found on this page:

http://smokefreediary.com/about/

  • DebatewiseDave
    • Design Lord, Child of Thor

    I have followed the instructions, or at least I think I have. Screenshots are attached of all my options and the error log is blank (if that's any help).

    Hopefully I've blanked out all identifying info from the screenshots, please let me know if not.

  • aecnu
    • WP Unicorn

    Greetings DebatewiseDave,

    Thank you for the additional input and the screen shots as well.

    Is the page – http://smokefreediary.com/about/ indeed a post or a page?

    If this is indeed a page you should be using a short code to place the like button i.e. [wdfb_like_button]

    I visited the page again and the error still exists. To detect and page errors – in Firefox or Chrome control+shift+J

    Now that you know how to check for the error(s) – it is time to go into full blown trouble shooting mode because it appears there may be some conflict there and one way to find out conclusively.

    Standard plugin trouble shooting protocol – first to switch to the Twenty Eleven theme just long enough to check for the problem – if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting.

    You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings DebatewiseDave,

    Thank you for the additional input which is certainly appreciated.

    Just checked the page again and now there are two Java Script errors on that page as indicated below:

    Uncaught TypeError: Object [object Object] has no method ‘popover’ application.js:50

    Uncaught TypeError: Object [object Object] has no method ‘affix’ application.js:18

    And of course the like button is not showing still.

    In addition, you have indeed proven out that it is a theme related issue of some type.

    We need to get these Java Script issues under control.

    Following standard troubleshooting protocol as mentioned above are you able to stop these errors?

    And when the errors no longer appear does the like button work as anticipated?

    Please advise.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.