Ultimate Facebook shuts down all but the home page tab

Oh boy, started this note before deactivating all plugins, then activating all slowly, now the problem does not seem to show, and Ultimate Facebook is not working even though it was not changed. I spent hours on this and now I need to rebuild many pages as I lost vital widgets, but no certainty that there is a final answer as the problem has not been duplicated and your plugin is not now working. Could it be the service provider problem?

(this was written prior to shutting off all plugins) I am at wits end, my site was working fine then I installed the Ultimate Facebook plugin, carefully set up according to (the helpful) video. It (worked) to post from buddypress activity feed to Facebook fan page fine... but all of my pages for vitals like donations, contact us, and the rest of the menu no longer work..."page not found" and all the info is still there in the WordPress editor, but cant even get 'view page' to work at that level. (also tried updating the page and changing around options there)

I tried reviewing each tick of Fb Ultimate, so far I can find nothing that changes this problem. All I can guess is that some setting, or method within the plugin is shutting down the pages and making them unable to be found.... Please what could I be missing, or what might be done to fix this? I am new to your system but the access is set up, I considered shutting down the plugin, but not certain if I would lose all the hard earned API info and settings. (that could be helpful to know for future considerations others may have)
Secondarily the Facebook sign up for a new member function seems to lock up too. Is there a good way to test it? ( since the info for my FB pages may make it appear that I am not a new member because of a Facebook fan page, personal page, & admin automatic selection; is there a sure way around this for testing the new member sign up process?)

The site is for a nonprofit, http://www.PrayersforPets1.org Home page was working fine; activity feed worked too and goes to FB fine at one point/// now not working with no change in the settings, only in and out with the plugins.

Thank you for any pointers you can give.

Victor

  • Nastia

    Hello Victor , I hope all is well!

    Would you please clarify, once you deactivated the other plugins the pages came back to normal? The pages are showing up for me now, I also tested the BuddyPress activity page and it is working there as well.

    Please clarify what is the issue you are having now, you can't post new updates on the activity Feed? Or the new posts re not auto-posting to Facebook?

    Would you please navigate to Facebook > Facebook Settings > Permissions & Tokens, check "Use minimal possible permission set" option and reset Auth tokens?

    Please advise,

    Cheers,
    Nastia

  • Victor

    Thanks for you quick response. I tried deactivating all plugins. At some point late in the process I cleared the cashe and restarted the computer, I am not sure but that may have helped to get the tabs/pages working, but at the same time nearly every plugin was off. Now I have more than normal plugins on, and the pages do not show up as "not found"...at least now. No lost pages today.

    BUT at the website, buddypress activity feed will no longer post to FB, which I tried several ways, ticked FB feed option, refreshing constantly, even w/o image- and no post shows in FB. I see your test, but now nothing works, though going at it from all angels I can think of.
    Ps As per your request I checked box for- use minimal permission, reset auth tokens, and saved.
    Feed to FB tried on many browsers, 3 different computers and they don't work. I can't see how you got it to go with a test, but the consistency of the site's response seems to change with same orders giving different results. The activity posts directly on the website seem to work fine but again the autopost to FB is not working. (yet had worked fine for me 30 hours ago until I noticed the menu tabs were dead, ie. so I know how it should work)
    Any help of course would be greatly appreciated.
    Victor
    https://www.facebook.com/PrayersforPets1/ http://www.prayersforpets1.org
    odd additional item, the Fan page itself has double posted a few times, posts made once directly on the FB page.

  • Victor

    I have discovered the error log and a report that obviously shows the FB Ultimate having problems. I had reset the token so I think that is resolved (thanks Nastia), but the later error seems to indicate that the API is not playing well. There is a link to the error but when going there to the Facebook developers site, there is no obvious help as it must be many layers deep into one of the various articles. I had very carefully installed the API as per the wpmudev video, but at one point it mentioned some choice types did not matter, perhaps that was not accurate to today's API settings, but I can not be sure as there seems to be no clear definition to the details. Please direct me to how I may solve this as posts from my tests from the Buddypress activity feed are (not) able to auto post to the given Facebook page.
    Thanks very much,
    Victor
    attached should be the error log and also a collection of all the settings. (support- I have backups please feel free to do anything you wish)
    [image pos="0"]

  • Nastia

    Hello Victor , I hope you are doing well today!

    I am so sorry for the delay in this thread.

    BUT at the website, buddypress activity feed will no longer post to FB, which I tried several ways, ticked FB feed option, refreshing constantly, even w/o image- and no post shows in FB.

    I tested the plugin on my installation and the activity posts were published successfully.

    I've checked the error log and the following message means that the facebook Application wasn't found:
    Unsupported get request. Object with ID '***' does not exist, cannot be loaded due to missing permissions, or does not support this operation.

    Which means that the API Key and the Secret Key are not correct or the Facebook Application is missing.

    So the first step here is to recheck your APP credentials, make sure that there are no blank spaces.

    Next please make sure that the Facebook Application is been approved from facebook and it is live. On the https://developers.facebook.com/apps/, select your app and navigate to APP Review and make the App public

    Although something telling me that the issue with the APP user ID, have you yourself authorized the app or someone else did it for you?

    Please note, in order to a post to be posted on Facebook, a person that shares a post need to be authorized. Resetting Auth Tokens should have solved this issue.

    But just to make sure, on the Facebook Application, navigate to Settings > Advances and check Age restrictions : 13+

    Let us know how it went!

    Kind regards,
    Nastia