Ultimate Facebook simply not working on one site

The ultimate facebook plugin or images is installed on http://www.philosophy.org but is not working at all. With the module published it only shows login text but no link and no images in posts.

Just to verify, I've followed the same procedure on another site, http://www.veteranscarpet.com and it seems to work very well.

Philosophy.org was originally built on a local MAMP installation and then uploaded to the live location before facebook was installed or attempted. We're using a YooTheme theme and maybe there's some sort of conflict. It also uses marketpress for the store.

Any ideas?

  • aecnu
    • WP Unicorn

    Greetings Justin,

    Thank you for this intriguing question it is certainly a brain burner.

    I do not have any ideas right off hand except to go into standard troubleshooting protocol to see what we can dig up if anything.

    With this in mind, I think the first step is to go into full blown trouble shooting mode because it appears there may be some conflict here and one way to find out conclusively.

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting. You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Justin,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • Justin
    • The Incredible Code Injector

    Hi Arun,

    Sorry for the delay, I've been working on the Marketpress and some other websites.

    I did a live preview with the twenty eleven theme and facebook buttons and comment box shows up.

    I'd like to add that this is the second site I've installed this on and through the WPMUDEV dashboard, both instances never finished the download and install. It seems to hang during installation.

    OK, so now we know it works with the other theme, what do we do next? Currently facebook comments are published but in the yootheme they simply don't show up and the buttons don't show up.

  • aecnu
    • WP Unicorn

    Greetings Justin,

    You should have check marked this as unresolved or we may have never seen your additional reply and you may think we are ignoring you.

    I will mark it as unresolved for us :slight_smile:

    You have proven that it is indeed a YooTheme theme problem or possibly more accurately an incompatibility of some sort.

    It can be pretty challenging to support other peoples work, but we do our best here to help and this will require custom coding of some sort to get it to work with your theme, probably to your theme itself.

    I understand the URL is http://www.philosophy.org and since I am not a professional coder I therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Justin
    • The Incredible Code Injector

    Joe, I think you and I posted at the same time so I was unaware this was closed. It wasn't resolved that's why I hadn't marked it as such.

    Yes, that site is the correct site and I have also submitted a request to YooTheme but I'm finding that their support is not nearly as good as it is here.

    Thanks again for looking into this.

  • aecnu
    • WP Unicorn

    Greetings Justin,

    Thank you for the additional feedback, it is greatly appreciated.

    I will see if I can get the lead developer to take a look at this theme/site and see if he can spot whats going on there and perhaps come up with a possible solution.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Vladislav
    • Dead Eye Dev

    Hello,

    I really don't like to pass the blame, but I'm afraid the problem could be related to the theme you're using. I haven't had any first-hand experiences with the particular theme you use on http://www.philosophy.org/, but some of the other Yoo themes I have seen before have had almost zero WordPress hooks implemented (long story short, "hooks" is what we use in most cases to connect plugin output to theme appearance). In this case, we might be able to get some custom changes made to your theme in order to get the comments and buttons to appear - the downside to this is that you'll have to remember to re-apply those changes when you update your theme to a newer version.

  • Justin
    • The Incredible Code Injector

    I'm more than happy to edit the templates if I know what to edit. I've submitted a support ticket to YooTheme about this and no reply as of yet.

    Let me know what changes I need to make and I'll make them. Thanks.

  • Justin
    • The Incredible Code Injector

    in-mn, so far I like the looks of their themes but the functionality and support make them inferior to the likes of say... StudioPress. I'm probably going to pull from their network as well.

    What other great theme developers or framework would you recommend? I've used several via Joomla but there are some that are horrible and very server intensive.

  • aecnu
    • WP Unicorn

    Greetings Justin,

    Thank you for your additional input.

    I like Theme Junkies and I personally stay away from framework themes because for some reason and speaking from experience here in the forums they pose special issues and in many cases need custom coding.

    That is my two cents on the subject ... lol

    Cheers, Joe

  • Vladislav
    • Dead Eye Dev

    Hi,

    I am not absolutely sure for your particular theme, but other Yoo themes I saw did come with a comments.php file. For Facebook Comments widget to appear, the solution is a two-step process, and step one involves editing this file. Once you decide where you want the comments to appear, add a bit of code that looks like this:

    <?php do_action('wdfb_facebook_comments'); ?>

    This is an entirely custom hook, so we're sure we're not stepping on any toes. Next, after this is done, navigate to your plugin settings > "Facebook Comments", and in the text input field named "Use a custom hook (advanced)" paste in "wdfb_facebook_comments" (without quotes). Basically, this way we're telling the plugin to use our custom hook to display the Facebook Comments widget.

  • Justin
    • The Incredible Code Injector

    I did try this but I get and an error:

    Parse error: syntax error, unexpected '<' in /home/username/wp-content/themes/yoo_revista_wp/comments.php on line 12

    Line 12 would be where I placed the code. Adding that also strips out all sidebars as well.

  • Justin
    • The Incredible Code Injector

    Hi Arun,

    Nope it doesn't work at all. The follow links don't even show up for facebook. I'm not getting the error anymore but nothing with the Ultimate Facebook and this theme seems to be working. Not even the module images and login.

  • Arun Basil Lal
    • New Recruit

    Hey Justin,

    Let me take a look at it, can you hook me up with a admin login and a ftp login? Please send it over to arun [at] incsub.com

    Not guarantees though, but I will do my best. In the email:

    - please include the link: https://premium.wpmudev.org/forums/topic/ultimate-facebook-simply-not-working-on-one-site
    - List out what you need to see accomplished. I see Facebook comments is one thing, the others seem to be vague to me.

    Looking forward to it.

  • Justin
    • The Incredible Code Injector

    Hi Arun,

    Thanks for taking a look at this.

    Here's the list:

    - Facebook comments
    - Ultimate facebook registration widget showing images and allowing to register to purchase products through marketpress.
    - Facebook Like button on posts and pages

    I think that's about it. I have no trouble configuring it to my needs once it's working with the theme but that's the part that doesn't seem to be working. I've also upgraded Ultimate Facebook to latest version and it seemed to go through quite well but no changes.

    I've sent you in an email all the required info and test the logins etc. You should be all set.

    Thanks again for taking a closer look at everything.

  • Justin
    • The Incredible Code Injector

    Hi Arun,

    I have no idea. When I created your username and password I even logged in and tested and had absolutely no problems accessing everything. I also tested the FTP as well. Now any admin I create I get the same error.

    Nothing new was added, no updates, nothing. I only made a backup but this was before I created your user.

    Any suggestions? I deleted your account, created a new one, still no go. Created a test admin, still the same thing. The only plugin I have is Advanced Access manager and I disabled that as well to test... NOTHING. It was on when I tested your login last week and it worked well. The only reason I have that is because there's not store manger functionality in Marketpress.

    What do you suggest?

  • aecnu
    • WP Unicorn

    Greetings Justin,

    Thank you for your additional input, it is certainly appreciated.

    Our lead developer did suggest that it is possibly a theme issue and I can see that you momentarily changed the theme to Twenty Eleven and indeed it worked from my understanding.

    Please keep us posted as to the status of this issue and if you indeed get this working with your current theme, please let us know how you did it for the benefit of other members.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Justin,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.