Ultimate Translate

Ever wanted all your translation automatically done for you, and then added to your sitemap?

Well, you'll be a fan of our new Ultimate Translate plugin:

https://premium.wpmudev.org/project/ultimate-translate

Let us know feedback / requests / bugs and other stuff here :slight_smile:

  • match11
    • Design Lord, Child of Thor

    Sorry. Yes. I mean 2.8.5

    however, a problem, I think???

    When plugin was placed into /mu-plugins/ the plugin failed to show but when plugin was added to /plugins/ and activated site-wide, the plugin was evident in all blogs. I activated translate settings and they show up on all blogs as prescribed by super-admin. I can automatically create a translation of a post and can read the translation via the post edit page - and an extract of the translated post appears in the language that it was translated on site wide widgets (such as site-wide posts) around the blog - however - when you click on the translated post to read the complete post - it sends the reader to the main english version of the post....

    It seems that it doesn't know where to go to see the translated version. Also, should the post have inserted code letting know if reader wants to opt out or read post in original language (ie, english)???

    Also, the widget accompanying the plugin does not show up in side panels.

    I'm using WPMU 2.8.5 with latest BuddyPress.

    Any help with this is most appreciated...

  • RomeoLab
    • Design Lord, Child of Thor

    @match11

    you don't have to put all the folder (ultimate-translation-plugin) in the mu-plugins folder. Just extract all the files and put them into the mu-plugins. That should work :slight_smile:

    James thank you for this plugin.

    P.S It will be great if we receive an email wenn new plugins are released :slight_smile:

  • Qlof
    • The Crimson Coder

    So this translated the posts and pages? Does it also translate hardcoded text like in themes and stuff like that?

    Good work on this one btw. Can it be added as a plugin instead of a mu-plugin? An earlier reply indicates that it can...

  • match11
    • Design Lord, Child of Thor

    Thanks RomeoLab

    Following your instructions made the plugin appear in the /mu-plugins/ folder and I can still create translations - but they will not appear in full using the /language/ folder as noted in the readme file.

    The translated post still redirects to the english post!

    Anyone got a suggestion?

  • arnonel
    • Site Builder, Child of Zeus

    same problems here

    instructions.txt not accurate

    guys, ive suggested before. please spend another 5-10mins creating accurate instructions.txt files

    also, might be a good idea to collate forum help/support into the instructions so that members dont have to trawl through the forums to make progress

    tx :slight_smile:

  • Andrew
    • Champion of Loops

    Hi Guys,

    So this translated the posts and pages? Does it also translate hardcoded text like in themes and stuff like that?

    It just translates posts/pages I believe.

    Can it be added as a plugin instead of a mu-plugin?

    Yep.

    We'll take a look at the installation instructions.

    Thanks,
    Andrew

  • match11
    • Design Lord, Child of Thor

    Hi Andrew

    I agree, install instructions in plugin(s) need to be a little clearer than what some are. Most times I get it... but sometimes they even contradict themselves. I noticed that the bp-community theme instructions were even incorrect.

    I still believe that there is a problem with the translation plugin. From what I know of php - and I'm not an expert - the plugin is failing to write the url location for the translated version.

    Something is amiss.

    Once again, many thanks. Any help most appreciated...

  • Austin
    • WPMU DEV Initiate

    I agree, install instructions in plugin(s) need to be a little clearer than what some are.

    You're right. I will update the installation instructions to make mu-plugins installations clearer.

    however - when you click on the translated post to read the complete post - it sends the reader to the main english version of the post....

    There are a couple of things that might cause this: for one, if you've clicked the "Do not show me translations any more" link, your browser gets a cookie that tells the plugin not to show you translations any more.

    But you also mentioned that you had the plugin in the /plugins/ directory on a WPMU installation, if I'm understanding correctly. You may need to update the rewrite rules on that particular blog in order to get them to take effect. (This is different from what you would do when the plugin is in the mu-plugins directory, which updates the rewrite rules across the site).

  • Qlof
    • The Crimson Coder

    Another question. On the wpmu-site where this is used, you automatically get to your countrys translation. Some visitors, like myself, would rather read the original english text. Is it possible for the visitor to choose to read it in its original, or even switch between several different languages?

  • match11
    • Design Lord, Child of Thor

    Hi Austin

    I updated the settings for the translation plugin (and it is located in the /mu-plugins/ folder and have let the "main blog" re-write the translation settings for each other blog in my wpmu site so it is up-to-date.

    Once again, the plugin is creating a translation of a post in a users selected language (which can be seen and read on the editing post page but when a user visits the post via the main site's aggregated post listing (with posts showing the translated language) - they are sent to the default english version of the post.

    What I am trying to say is that on the list of translated post on the front page of my wpmu site, the link to the translated post is the link to the english version not the translated version.

    For example: A excerpt of a spanish post is seen on the front page of my wpmu site written in spanish but it points to:
    http://myblog.xxxx.com/2009/11/9/my-new-post/
    not http://myblog.xxxx.com/2009/11/9/es/my-new-post/

    When I manually go to http://myblog.xxxx.com/2009/11/9/es/my-new-post/, my site redirects me back to http://myblog.xxxx.com/2009/11/9/my-new-post/.

    It's as if the spanish version doesn't exists.

  • James Farmer
    • CEO (of WPMU DEV, honest)

    @Qlof:

    "Is it possible for the visitor to choose to read it in its original, or even switch between several different languages?"

    Each translated post has at the top of it the option for the reader to read the original and/or never view translated versions of posts (saved by cookie).

    We don't have the option for readers to view posts in diferent languages yet but I guess that might be a nice drop down widget... what do other peopel thing about that?

    @match11 that sounds like expected behaviour based on your redirection settings? If you set it to redirect based on browser language and then set your browser language to spanish you should always see the spanish option?

    Austin can help in more detail though.

    If you could provide us with some real links (unless you own xxxx.com :slight_smile: that'd be fantastic too.

  • Austin
    • WPMU DEV Initiate

    On the wpmu-site where this is used, you automatically get to your countrys translation. Some visitors, like myself, would rather read the original english text. Is it possible for the visitor to choose to read it in its original, or even switch between several different languages?

    There is a widget that comes with the plugin. If you enable that widget and have allowed multiple languages, visitors can select from a dropdown which language they want to read the post in.

  • Austin
    • WPMU DEV Initiate

    Ahhh, so the problem is the posts appearing in recent sitewide activity... to be honest we haven't made this BuddyPress compatible yet (see the compatibility tags) but I guess we should.

    Austin can fill you in more.

    Yes, the problem is that BuddyPress has its own permalinks functions that print the links to the various posts, such as those in the recent sitewide activity area.

    We'll need to adjust the plugin to accommodate BuddyPress.

  • match11
    • Design Lord, Child of Thor

    I get what you're saying but there is still a bug in the system.
    I can't make this any clearer I'm afraid. This is the situation....

    - I have wpmu 2.85 installed
    - Buddypress 1.1 installed
    - translation plugin is in /mu-plugins/
    - translation plugin settings are correct
    - Widget is enabled an on blogs
    - Users can create posts in a variety of languages (See example attachment)

    But when a reader chooses the language from the widget to view a post in a different language - it redirects the page to the default english language post!

    There is a redirection bug in the plugin!

  • Austin
    • WPMU DEV Initiate

    match11, it seems like your rewrite rules haven't been generated.

    On the Ultimate Translation settings page, try changing the "Blog Admin Access" and "Automatic Translation" options from whatever they currently are to the other setting, press "save," and then change them again and press "save." You should be prompted with a dialog box to rebuild the permalinks rules. What happens when you do that?

    (Actually you'll be prompted twice to rebuild the permalinks rules: once for each time you press "save." Just close the prompt the first time, as you want to rebuild the rules only for your original settings.)

  • match11
    • Design Lord, Child of Thor

    I have changed settings and then changed them back and the rewriting process was successful (see screenshot at 66% rewrite) but I think it is not rewriting rules as the same problem occurs.

    Where do these rewrite rules reside? Can I change them manually?

  • Austin
    • WPMU DEV Initiate

    Where do these rewrite rules reside? Can I change them manually?

    WordPress stores the rewrite rules as an array of data in the database. In WPMU and BuddyPress, each set is stored in each individual blog's options table, under the option "rewrite_rules." Unfortunately, this is not something that can easily be adjusted directly.

    It is possible to view the current rewrite rules using troubleshooting plugins, such as dump_env.php, but I wouldn't recommend that for a production site, because it potentially exposes a lot of information about the site.

    I will test the translation plugin on BuddyPress and see if there's something peculiar to BuddyPress that's keeping the rewrite rules from being properly generated.

  • match11
    • Design Lord, Child of Thor

    Further to this problem,
    I have checked the database and found all the rewrite rules as well as the posts in different languages in the database tables etc - so I know the plugin is working as it should- but it just won't let the reader see or visit the translated post/page. It just re-directs reader back to default english post!

    I think Buddypress may have something to do with this?

    Anyone using this plugin without problem?

  • Austin
    • WPMU DEV Initiate

    I have checked the database and found all the rewrite rules as well as the posts in different languages in the database tables etc

    match11,
    do you see something like the following the rewrite rules? (The two-letter language codes might be different depending on your settings.)

    (da|dv|fr|de|el|gn|gu|km|ko|ku|ne|no|or|si|sk|sl)/feed/(feed|rdf|rss|rss2|atom)/?$] => index.php?language_pattern=$matches[1]&feed=$matches[2]

    If so, that would indicate that the rewrite rules are in place.

  • learnthat
    • New Recruit

    First of all, great plugin!

    Next, is there an errant </script> in this section of the ultimate-translation-plugin.php file, or should it be in there?

    function widget( $args, $instance ) {
    extract($args);
    $title = apply_filters('widget_title', empty($instance['title']) ? UTP_L::__('Select a Language') : $instance['title']);

    $alloweds = apply_filters('ut_allowed_languages', array());

    if ( ! empty( $alloweds ) ) :
    echo $before_widget;
    if ( $title ) {
    echo $before_title . $title . $after_title;
    }
    $lang_query_var = UTP_L::get_requested_language();
    ?>
    </script>
    <select name="ut-select-language-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>

    Thanks,
    Jeremy

  • TeamFUtd
    • Design Lord, Child of Thor

    Just a quick thought - I'm noticing the same problem as one of the original posters in this thread that when dropping the ultimate-translation-folder into mu-plugins that it wasn't showing up/working.

    The suggested work around for this is to place all the files containted within ultimate-translation-plugin folder into mu-plugins but this is a pain. Ok, it's not many files but we've a lot of other files in our mu-plugins folder so they just get lost in there and harder to manage.

    Could a fix for this be considered in the next release please?

    Cheers

  • TeamFUtd
    • Design Lord, Child of Thor

    @austin - thanks very much mate!

    also, can i just confirm that for the widget drop down to work, I need to first update the settings (ie pick the languages, click not to automatically translate and then click translate all) as I can't seem to tget it to appear otherwise

    (i notice that if I don't click on 'translate all' then the language choices don't remain when I click 'save all changes' at the bottom)

    I'm just a little confused with it all atm!

  • Ronnie Burt
    • Hosting & Biz Dev

    You know what would be really cool - not that this plugin isn't already - but to have the option of adding the language selector to the buddyPress admin bar. This way, the language could potentially (maybe, hopefully) also be something like the native dashboard plugin and allow users to select language for the dashboard/profile etc. Thanks!

  • moelleren
    • New Recruit

    Hi there.

    It looks like my wordpress installation is working forever on traslating. It has been working 15 minutes, translating two posts (or so it says). Is this really the way it should be?

    WordPress is currently processing the translation request. 2 of 113 posts and pages have been translated.

    I only signed up for this website, to download this plugin. If it doens't work I would love to have my money back.

    Thanks.

  • Austin
    • WPMU DEV Initiate

    Hello moelleren,

    Have you disabled JavaScript in your browser? How many languages are you translating those posts into?

    If you tell WordPress to translate the posts and have JavaScript disabled or leave the page, the plugin will use WP "cron" jobs--WordPress's built-in automated scheduling of events--to make sure the translations continue.

    It might take a while if there are a lot of translations, but if stalls completely, that might indicate that WP is having problems with its cron functionality.

  • Jeremy
    • New Recruit

    Hi, great plug-in concept. I'm stumped on what's happened after I tried to use the 'Translate Everything' feature, though...

    I activated the plug-in on a single blog within my MU installation. I selected a few (~5) languages to translate the 434 posts and ~40 pages to. After clicking 'Translate Everything', the plug-in's status bar appeared, and after a few minutes the progress % was moving. I left it alone, and let it run over night.

    In the morning I checked the plug-in settings page, and the status bar was gone. Not sure if that meant the translate process had finished, so to check I installed the widget and on the front-end selected one of the languages listed. When I did this the page refreshed, but the content wasn't translated, and the page URL didn't change.

    Later that morning my server crashed and had to be re-booted (twice), due to spikes in memory usage. I'm not sure if this is related to this plug-in or not, but this doesn't happen often, and it's never happened to me twice in the same day before.

    Finally, I checked the XML sitemap for the blog I was trying to translate, to see if any new language URLs had been added. The sitemap is no longer there. So I looked to the XML Sitemap plug-in, which gives me these error messages:
    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts.
    # The last known memory usage of the script was 20MB, the limit of your server is 64M.
    # The last known execution time of the script was 3.16 seconds, the limit of your server is 120 seconds.
    # The script stopped around post number 488 (+/- 100)

    I tried to 're-build the sitemap manually' (using the XML Sitemap plug-in), but no luck (same messages appear; still no sitemap).

    I have since deactivated the Ultimate Translate plug-in.

    There are a lot of related parts to this issue, and I'm not sure what's causal, versus coincidental. But if you can shine any light on this I'd appreciate it.

    Thanks,
    Jeremy

  • Jeremy
    • New Recruit

    Follow up to my post above: I deactivated the Ultimate Translate plug-in, then tried to rebuild my sitemap...and the sitemap build worked. So the Ultimate Translate plug-in was interfering with the XML Sitemap plug-in.

    I'd still like to know how to get the Ultimate Translate plug-in to work. Thanks!

  • Austin
    • WPMU DEV Initiate

    Jeremy, I'll have to look into whether Ultimate Translate could be directly interfering with XML Sitemaps plugin; I can't think of any reason it would, but anything is possible.

    Translating a lot of posts at once is going to take a lot of memory, the XML sitemap plugin uses a lot of memory, and 64mb is low even for a vanilla WordPress blog. I'm not sure what can be done about that aside from increasing the memory. On the positive side, translating 400 posts isn't something you probably will have to do regularly, so in regular usage the memory tax should go down.

  • gastrodev
    • New Recruit

    Server: Mac OS X
    Wordpress: 3.0 (Multisite enabled)
    Ultimate Translate Version 1.0.1

    I am testing Ultimate Translate on new installation (no other plugin installed).

    After install I selected:
    one language: de
    * Manual
    * Individually-selected Posts & Pages Translated
    * Do not redirect visitors on language guess

    After saving a rebuild (rewrite rules for all blogs) completed successfully.

    I go to edit/translate the Hello World post.
    Select: * Translate this page or post, *Manually translate this page or post
    When I press the "translate to German Link"

    NO TEXTBOX TO EDIT THE TITLE OR THE POST APPEARS!

    Only a "Delete" link appears (but no button with the language name).

    I guess there is a javascript-conflict with Wordpress 3.0
    Hope somebody could help.

    -----------
    The database shows:
    wp-options:
    ut-allow-wpmu-blog-settings 0
    ut-allowed-language-codes a:1:{i:28;s:2:"de";}
    ut-make-page-translation-automatic 0
    ut-translation-scope -1
    ut-translation-guess-lang 0

    wp-sitemeta:
    active_sitewide_plugins a:1:{s:59:"ultimate-translation-plugin/ultimate-tr...
    ut-all-rewrites-need-updating 0
    ut-allowed-language-codes a:1:{i:28;s:2:"de";}
    ut-translation-scope -1

    wp-post:
    5 1 2010-07-25 18:10:28 2010-07-25 18:10:28 [ Enter Translated Content Here ] [ Enter Title Here ] publish open open hello-world 2010-07-25 18:10:28 2010-07-25 18:10:28 1 4d8b2019a04df41acaf83b5101d64e5e 0 ut-localization 0

  • swissroller
    • Flash Drive

    Hi Guys,
    I'm running one of my sites on WP3 and have installed ultimate translate plugin. No problems with installation and the plugin activated. I'm using edu-clean parent as a template.
    The plugin is happily working away translating the 25 or so pages I have on the new site as I write.
    The problem I have is getting the drop down menu to show on the page. I am using exactly the same theme on a related site which is an MU installation and there are no problems there.

    Any ideas... or could it be it's not showing because it's still translating the text ?

    Evelyne

  • john
    • Flash Drive

    Hi guys,

    i have the same problem as gastrodev : see snap below.
    also running WP 3.0.1 and latest version of Ultimate Translate.

    This is a priority 1 issue i think. Can you let us know of progress please ?
    thanks
    john

  • swissroller
    • Flash Drive

    Hi Barry,
    thanks for this. I have updated the plugin on two sites as detailed below. The plugin now shows on my pages but not on the home page.
    I am running Edu-clean on both a WPMU installation on one site Most recent version ( sorry I don't know the number ) and another site is running wp 3.0.1 with the same result.
    Is it the template maybe?

    Any advice will be greatly appreciated...

    cheers,

    Evelyne

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.