Ultimate Translate

Using the Ultimate Translate, I created a page, then selected

Translate This Page or Post
Automatically Translate this page or post
Translate into Spanish

I get the drop down option on this page, I select Spanish but the page is blank
http://domain.com/es/about/

I read these instructions
https://premium.wpmudev.org/project/ultimate-translate

  • Barry
    • DEV MAN’s Mascot

    This seems to be the main error I keep seeing:

    [26-Jul-2010 02:38:11] PHP Warning: include_once(/home2/domaincc/public_html/mydomain/wp-content/mu-plugins/includes/wp-sequential-task-scheduler.php) [function.include-once]: failed to open stream: No such file or directory in /home2/domaincc/public_html/mydomain/wp-content/mu-plugins/ultimate-translation-plugin.php on line 37

    Can you check if that file exists (the first one)?

  • drdave
    • The Crimson Coder

    Hi Barry just now getting back with you. Please bare with me as I have no clue how this plugin is supposed to work.

    I had to reinstall Wordpress 3.0.1 and so far everything is running smoothly with Blogs MU Theme. I installed "Ultimate Translate” plugin once again with these settings…

    Allow Blog Admins to Configure Translation Settings
    All Posts & Pages Translated
    Languages to Translate - Spanish
    Do not redirect visitors on language guess

    Added a widget to “Left Side Bar” which appears on post pages never on static pages.

    Started a post with these settings.

    Translate this page or post
    Automatically Translate this page or post
    Clicked on translate in Spanish
    Save Translation

    Now I have no clue if “Manually Translate this page” means I have to get my own translation pages and add them but if so add them where? But I also tried “Automatic Translation” and my results were the same.

    Either option gave the same results seen in the attachment.

    It also appears that the dir path for this translated page in my browser has not been created by checking in ftp as well as cp http://my site.com/blog/es/premium-tools/ but the attached file you see is the results I see in that path. I am sure there is something in this process I do not understand. Maybe a php process not sure.

    To clarify, /blog/es/premium-tools/ not seen on my server only in web browser

    Would love to get this going.

    Thanks

  • Aaron
    • CTO

    o clarify, /blog/es/premium-tools/ not seen on my server only in web browser

    Not sure what you mean by that, but permalinks in WP will not create actual directories on your server.

    Also there is a small bug we're fixing where manual translating does not work. Doing it automatically should be fine though. Are you still getting any errors in your log?

  • drdave
    • The Crimson Coder

    Aaron you answered my question "permalinks in WP will not create actual directories on your server." Thanks

    As far as error log...

    /home2/mainsite/public_html/notthemainsite/wp-admin/error_log: [02-Aug-2010 00:05:35] PHP Warning: unlink(/home2/mainsite/public_html/notthemainsite/wp-content/blogs.dir/1/thumbs/blogsmu5.jpg) [function.unlink]: No such file or directory in /home2/mainsite/public_html/notthemainsite/wp-content/themes/blogs-mu/_inc/functions/services-functions.php on line 1789 [02-Aug-2010 00:05:35] PHP Warning: unlink(/home2/mainsite/public_html/notthemainsite/wp-content/blogs.dir/1/thumbs/blogsmu5_thumb.jpg) [function.unlink]: No such file or directory in /home2/mainsite/public_html/notthemainsite/wp-content/themes/blogs-mu/_inc/functions/services-functions.php on line 1790 [02-Aug-2010 00:06:05] PHP Warning: unlink(/home2/mainsite/public_html/notthemainsite/wp-content/blogs.dir/1/thumbs/blogsmu5.jpg) [function.unlink]: No such file or directory in /home2/mainsite/public_html/notthemainsite/wp-content/themes/blogs-mu/_inc/functions/services-functions.php on line 1789 [02-Aug-2010 00:06:05] PHP Warning: unlink(/home2/mainsite/public_html/notthemainsite/wp-content/blogs.dir/1/thumbs/blogsmu5_thumb.jpg) [function.unlink]: No such file or directory in /home2/mainsite/public_html/notthemainsite/wp-content/themes/blogs-mu/_inc/functions/services-functions.php on line 1790 [02-Aug-2010 01:19:22] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 for query SELECT * FROM wp_term_counts WHERE ( ) made by include, do_meta_boxes, call_user_func, Ultimate_Translation_Plugin_Admin_Handler->print_postbox_wrap, Ultimate_Translation_Plugin_Translate->create_translated_object, wp_insert_post, do_action, call_user_func_array, post_indexer_post_insert_update, post_indexer_post_terms_insert_update [02-Aug-2010 01:19:22] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 for query UPDATE wp_term_counts SET term_count = term_count + 1,term_count_updated = '2010-08-02 01:19:22' WHERE ( ) made by include, do_meta_boxes, call_user_func, Ultimate_Translation_Plugin_Admin_Handler->print_postbox_wrap, Ultimate_Translation_Plugin_Translate->create_translated_object, wp_insert_post, do_action, call_user_func_array, post_indexer_post_insert_update, post_indexer_post_terms_insert_update

  • Barry
    • DEV MAN’s Mascot

    @drdave - you still seem to be getting *a lot* of missing file warnings in those logs - now it's in the blogsMU theme folders - and that final db error.

    My first concern would be sorting the missing files, can you go through the log (most recent entries) and check that the file you are getting warnings for actually exist on the server - with that many (from this log and the previous), I'd be looking at reuploading things myself, but then I often take these drastic steps :slight_smile:

  • drdave
    • The Crimson Coder

    Following the most recent error log on my server which is the same as the very last one I posted (Posted on 2nd August 2010 (1 day ago))...

    All of these exist...
    /wp-content/blogs.dir/1/thumbs/blogsmu5.jpg)
    /wp-content/themes/blogs-mu/_inc/functions/services-functions.php
    /wp-content/blogs.dir/1/thumbs/blogsmu5_thumb.jpg)

    tmk those are the only files in the error log so hopefully I did not miss anything.

    Now the previous log (Posted on 30th July 2010 (4 days ago) I think can be ignored. I literally deleted everything from my server since and did a clean install with this new theme. Of course I stand corrected.

  • john
    • Flash Drive

    thanks a lot Barry,
    found it, installed it and that issue is now cleared :slight_smile:
    i can select a language to translate and the translation is saved.

    when i view the post it appears in its original language
    however when i want to select an alternative language from the language widget selector, the chosen language doesn't show :
    see here an example
    http://basites.net/2010/08/03/blog-test-entry/

    am i doing something wrong in the config of the plugin or am i missing something ?

    thanks
    john

  • drdave
    • The Crimson Coder

    Hey James I am still at my last post before the hijack "Posted on 3rd August 2010 (2 days ago) #" nothing changed since.

    In response to Barry...

    Following the most recent error log on my server which is the same as the very last one I posted (Posted on 2nd August 2010 (1 day ago))...

    All of these exist...
    /wp-content/blogs.dir/1/thumbs/blogsmu5.jpg)
    /wp-content/themes/blogs-mu/_inc/functions/services-functions.php
    /wp-content/blogs.dir/1/thumbs/blogsmu5_thumb.jpg)

    tmk those are the only files in the error log so hopefully I did not miss anything.

    Now the previous log (Posted on 30th July 2010 (4 days ago) I think can be ignored. I literally deleted everything from my server since and did a clean install with this new theme. Of course I stand corrected.

  • Barry
    • DEV MAN’s Mascot

    @drdave - if possible, can you start a new thread here on the forum with your current status and latest issue / log? Would help me enormously as I'm starting to lose track on which issues we still have outstanding, and which are solved.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.