Unable to access Multisite sub-directory dashboards

I have a Multisite installation that uses subdirectories. I haven't done any work on the sites for the last few months, but now when I attempt to access the Dashboards I get the following error message:
"The site is experiencing technical difficulties."
The front-end of each installation looks fine, and I am able to access the Dashboard of the primary site.
Any ideas?

  • Adam Czajczyk
    • Support Gorilla

    Hello Greig

    I hope you're well today and thank you for your question!

    The message that you're getting is, unfortunately, a bit "enigmatic" so it's hard to say what exactly is happening. Usually, however, it means there's some "under the hood" 5xx error.

    If you didn't make any serious changes on site on purpose, that'd probably be related to either some updates or some changes on server done by the host. I suggest starting with these simple tweaks though:

    1) check the site in "network admin -> updates" and make sure that everything (WP core, themes, plugins) is up to date; there's a good chance that you'll notice an "upgrade network" option there so if you do - please run it

    2) if there's any kind of cache on site/server (or both) clear them all entirely

    If that still doesn't help, do this:

    3) go to the "Network Admin -> WPMU DEV -> Support -> System Info" page and
    - in "WordPress" tab check value of WP_MEMORY_LIMIT
    - in "PHP" tab check value of "memory_limit"

    - if WP_MEMORY_LIMIT is lower than "memory_limit", edit your site's wp-config.php file and right above the "/* That's all, stop editing */" line, add following line

    define( 'WP_MEMORY_LIMIT', '256M' );

    where 256M should be replaced with the value of "memory_limit" from PHP tab.

    If that still doesn't help, I'll need to take a closer look. In that case, please enable support access to the site by going to the "Network Admin -> WPMU DEV -> Support -> Support Access" page and clicking on "Grant support access" button there and let me know once it's done (as I won't be notified automatically).

    Best regards,
    Adam

  • Carlos
    • New Recruit

    Hi there,

    As Adam Czajczyk says, it seems to be related to changes on your server side. By the way, check your wp-config.php and .htacces files with the right multisite configuration (look at Network Admin -> Settings -> Network Setup).

    Taking advance of that you are at wp-config.php, check if you have defined any of these constants:
    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');

    If so, comment on that line and try to access again. Hope it helps.

    Kind regards,
    Carlos

  • Adam Czajczyk
    • Support Gorilla

    Hello Greig

    Thanks for enabling access!

    I checked the site and it seems that there's been (probably more than one) upgrade of WordPress since the time when it was all working for you. It's a multisite and upon update it's usually necessary to also run "network upgrade" which, in this case, wasn't performed.

    The error message seems to confirm (if you look into the browser address bar, at the redirect address) that this might be related here.

    That being said, would you please go to the "Network Admin -> Dashboard -> Upgrade Network" page and perform network upgrade from there? After it's complete, make also sure to Purge SG Cache fully and see if the issue is solved.

    Please note: I didn't do it for you because through the support access I wouldn't be able to do anything more in case something went wrong. I would strongly recommend to make sure that there's a full backup of the site (might be e.g. cPanel backup) before performing the operation - just in case.

    Best regards,
    Adam

  • Greig
    • WPMU DEV Initiate

    Hi Adam

    I honestly can't remember the last time I saw the "Please visit the Upgrade Network page" message, so there would have been a number of WP updates since I last did this.

    I'm not seeing any change. I did wonder if perhaps the Upgrade Network process was going through iterations and needed to do an upgrade for each update?

    Best regards,
    Greig

  • Predrag Dubajic
    • Support

    Hi Greig,

    Could you try enabling debug log on your site so we can see if we can get some more information about the error from there?

    You can enable debug log in your wp-config.php file (located in root WP folder) by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'log_errors', 1 );
    @ini_set( 'display_errors', 0 );

    Visit the subsite admin so that the error shows again and this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Greig,

    Thanks for the log, this did indeed tell us where the issue is.
    As you can see in the logs there's fatal error going on that is pointing to this file /wp-content/plugins/genesis-widgetized-notfound/includes/gwnf-widget-areas.php and that is the path to Genesis Widgetized Not Found & 404 plugin.
    When I disabled this plugin your subsites started working again so you should be able to access their backend now.

    I tried searching for similar reports online but I'm afraid that I wasn't able to find much information about it.
    It could be related to child themes and you could check if this by switching to Genesis parent theme and then reactivating Genesis Widgetized Not Found & 404 plugin to see if the backend loads in that case.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.