Unable to access wp-admin login page due to errors

Hi there,
I truly hope I’m asking for help in the right place. When I last checked 2 months ago my website was running fine. Today I went to log in and to my surprise I was met by errors instead of the wp-admin login page (I think it was caused by wordpress automatically updating). I searched quite a bit and was able to remedy the first few problems, however new ones have popped up in their place.

This is what I’ve done so far via FTP: I’ve updated to the newest version of wordpress keeping my original wp-config.php and also wp-content folder except for index. I disabled all plugins by renaming the plugin folder. I disabled all themes except for twentyseventeen by renaming them (my website was built using a third party theme which I disabled in hopes of being able to bring back my wp-admin login screen with no luck).

These are the errors that are currently preventing me from getting to the wp-admin login page:

Warning: include_once(/home4/rosales/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase1.php): failed to open stream: No such file or directory in /home4/rosales/public_html/wp-content/advanced-cache.php on line 10

Warning: include_once(): Failed opening ‘/home4/rosales/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase1.php’ for inclusion (include_path=’.:disappointed:opt/php54/lib/php’) in /home4/rosales/public_html/wp-content/advanced-cache.php on line 10

Warning: Cannot modify header information – headers already sent by (output started at /home4/rosales/public_html/wp-content/advanced-cache.php:10) in /home4/rosales/public_html/wp-includes/pluggable.php on line 1179

Any help will be greatly appreciated. Thank you in advance!

  • Adam Czajczyk

    Hello Rosales,

    I hope you're well today and thank you for your question!

    You did some really great troubleshooting there! :slight_smile:

    I think solving that last error should let you access the site. The error indicates that there was WP Super Cache plugin installed and disabling it by simply removing (or renaming) plugins folder can cause additional issues, unfortunately. Here's what you will want to do:

    1. edit your "wp-config.php" file and either comment out or just remove this line

    define('WP_CACHE', true);

    2. ediit the ".htaccess" file in your WordPress root folder and remove all the rules marked as added by Super Cache; they should be clearly marked and placed between two clearly stated comment lines.

    3. remove these files:

    /wp-content/advanced-cache.php
    /wp-content/wp-cache-config.php

    4. and this folder

    /wp-content/cache/

    Clear you browser cache and try to access the site again. Let me know if that worked for you, please.

    Best regards,
    Adam

  • Rosales

    Adam! Thank you so much for the quick help! It worked like a charm! I am in my dashboard however, another problem has presented itself :slight_frown: As I previously told I renamed my plugins folder and themes to troubleshoot. Well I undid the renaming and now neither my plugins nor my themes work. My themes are not showing up in my dashboard even after renaming. I have even tried to reinstall but I get: "Installation failed: Could not create directory" for wordpress native themes. Also when I go to install the third party theme that I use I get:
    "Unpacking the package…

    Installing the theme…

    Could not create directory. /home4/rosales/public_html/wp-content/themes/Total/

    Theme install failed."

    My plugins are all showing up in my dashboard I can activate them but they have no effect on my website at. I don't have a back-up of the folders before I tried to troubleshoot because something went wrong somewhere and my theme and plugins folders are empty in the back-up.

    How can I go about fixing this mess I've got myself into?

    Thank you in advance and have a great day!

  • Adam Czajczyk

    Hello Rosales!

    I'm glad I could help :slight_smile:

    After renaming folder back to as they were, plugins and themes should show up again (respectively) on "Plugins -> All plugins" and "Appearance -> Themes" pages in your site's dashboard.

    If a plugin and/or theme is present inside these directories, you won't be able to install it again unless you delete its files, so that explains why you got these "Install failed" messages. I'm not sure however why you can't see themes where they should be and why your plugins doesn't get activated as expected.

    I would like to take much closer look at this case so would you mind letting me access your site and server directly? For this please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site
    - include a list of plugins that should be enabled on the site

    Please use our contact form here http://premium.wpmudev.org/contact/

    Select "I have a different question" from the drop-down list. 

    Please be sure to make a full backup of your entire site first!

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.