unable to activate page caching

Can't activate page caching... keeps giving me the following error:
Error: The wp-content directory is not writable. Ensure the folder has proper read/write permissions for caching to function sucesfully.

I have tried various permissions for wp-content and it's subfolders.. like 755, 750, 777 and nothing helps.

  • Katya Tsihotska

    Hi Michael

    Hope you're having a great day!

    Could you try to apply solution provided by Anton here:
    https://premium.wpmudev.org/forums/topic/hummingbird-file-system-issue#post-1290993

    If it doesn't help, I'd request you to perform the following test:
    Enable wp debug. To enable WP_DEBUG, change the following line in your wp-config.php file:
    define('WP_DEBUG', false);
    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    Please make sure to add the above code just before the line /* That's all, stop editing! Happy blogging. */

    After this, try to replicate issue again. Then go to /wp-content folder and check if debug.log file is there. If it's there. download it, save as debug.txt and attach to your next reply.

    Also, could you please grant us temporary support access to your website so we can have a better look at your setup and settings? You can grant us access via WPMUDEV Dashboard plugin, there's no need to share credentials. Here's our detailed documentation page about it:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Kind regards,
    Katya

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.