Unable to change fundraiser directory

Hi,

I have been using the Fundraising plugin successfully for some time, but after updating the plugin, I am having a very weird issue.

I previously used wdf-funder.php to style the individual look of the fundraisers, and content-article to change "the loop" which displayed the fundraising directory. This worked great.

However, since updating the plugin, the "fundraising directory" (i.e. 'view all' fundraisers) seems to be drawing from the page type wdf-funder.php and not from the content-archive.php. I have found this out from using these instructions: http://wordpress.stackexchange.com/questions/37292/how-do-you-find-out-which-template-page-is-serving-the-current-page

Therefore I added archive-funder.php as recommended in other support threads however that is not working; it is still wdf-funder.php.

Any advice would be gratefully received!

  • Sajid

    Hi @georgieemcrae,
    Hope you are doing good today :slight_smile:

    I tested it on my own website and its working just fine for me. I renamed archive.php file to archive-funder.php file and its correctly started loading this template.

    Make sure, there are no spelling mistake and its exactly archive-funder.php file.

    If it did not worked than please send in FTP and WordPress admin login details so I can see how you have setup custom template. If its okay for you then send in these details using our contact form in following format.

    Subject: "Attn: Sajid Javed"
    -Error log file link
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me

    https://premium.wpmudev.org/contact/

    Take care and have a nice weekend :slight_smile:
    Cheers, Sajid

  • Sajid

    Hi @georgieemcrae,
    Hope you are doing good today :slight_smile:

    I am sorry for delay on this ticket, but please make sure we do all the conversation related this topic on this ticket instead of private emails.

    Thanks for sending in the FTP details, it helped figure out what is the issue exactly. Its not loading the archive-funder.php file because you have wdf_funder.php file. According to plugin template hierarchy wdf_funder.php template higher precedence than archive-funder.php file.

    So if you want to use archive-funder.php file then remove or rename wdf_funder.php template file. This will fix the issue.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:
    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.