Unable to Deactivate Plugins

I am trying to deactivate or delete any plugins. The only change I have done is I did sign up for the free trial of WPMU DEV. I am unable to deactivate that plugin as well.
Any suggestions?
Peter

    Adam Czajczyk

    Hello Peter,

    I hope you're well today and thank you for your question!

    The trial subscription shouldn't interfere with an ability to deactivate plugins. Was the installation of WPMU DEV Dashboard plugin the only change you have made to the site? When you try to deactivate any plugin does it return any error/notice message or it just doesn't take effect?

    Would you mind granting me a support access to the site so I could test myself? To do this please follow this guide and let me know here when its enabled:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Best regards,
    Adam

    Peter

    Adam,
    Thank you for your response.
    When I am trying to deactivate plugins I click on "deactivate", there are no error messages, at the top of the plugin page I see a green bar that states plugin deactivated however, it does not take effect.
    One thing I have noticed is that I installed the plugin Smart Crawler and started to run the report on my site for SEO recommendations. The bar got to 46% completed and then stated that it lost connection. I tried to run the report again and the bar is stating that crawler is already running. I believe the report run is stuck.
    I have followed your instructions to allow you access to my site for 5 days.
    Please advise,
    Thank you!
    Peter

    Adam Czajczyk

    Hello Peter,

    Thank you for for granting access and sharing additional information.

    I accessed and checked your site and I can confirm the issue, though I admit it's a strange one I tried to make some small changes to the site to get past it but they didn't work, there's also no errors in a console and nothing in setup indicates potential troubles.

    That said, can you please run two additional tests?

    First one would be to disable W3 Total Cache caching - all the options, then clear browsers cache and see if you can then disable plugins.

    If that doesn't help, the second test would be a full plugin conflict test:

    - access the site via FTP (or cPanel's "File Manager" tool)
    - disable all the plugins by renaming "plugins" folder inside "/wp-content" folder to "plugins.hold"
    - then login to the site as an admin and go to "plugins -> all plugins" page; you should now get a message that plugins were disabled
    - after that rename "plugins.hold" folder back to "plugins"
    - on "Plugins -> All plugins" page try enabling two plugins. If they are enabled try disabling one of them. if that works, enable it back and enable yet another one, then again try disabling one of them, I hope you get the idea

    Let's see if that points to any conflict. Let me know about results, please.

    Best regards,
    Adam

    Adam Czajczyk

    Hello Peter!

    Thank you for your replay. That would confirm that the main culprit here was the W3 Total Cache so I think it's not even the plugin itself but some if its settings. You might want then to enable the plugin back and then disable all the caching and optimization options in it and then try to enable them back one by one, playing with its configuration a bit, to find out a proper setting that will at the same time let you cache the site but not break its functionality. That's however a "trial and error" procedure.

    Best regards,
    Adam