Unable to edit post in Upfront editor by clicking title or content

Currently I'm unable to edit a newly created post in the Upfront editor

The simple action of being in the Upfront editor and then double clicking the post title or content area does nothing.

Currently running:
* Spirit 0.1.6
* Upfront 0.3.2.1
* WordPress 4.2.2 clean install - no plugins

Using browser: Google Chrome 43.0.2357.124 m

A JavaScript error is seen in the console:
Uncaught TypeError: Cannot read property 'length' of undefined

See attached screenshot for error, location and watch variables which might be of interest.

  • Vinod Dalvi

    Hi Dean,

    Thanks for posting on the forum.

    Are you trying to edit the content of post on single post page?

    If yes then you can't do it as it's the single object which can only be edited from the admin area.

    I have just tested it on my test site using latest version of Spirit theme but i didn't get such JavaScript error.

    Editing text is working fine for me for text elements but it doesn't work on single post page as described above.

    Kind Regards,
    Vinod Dalvi

  • Dean Taylor

    The steps to reproduce the issue are basically:
    - enter upfront edit mode from homepage
    - click the "New Post" button from upfront panel on left
    - wait for new post page to load
    - click / double click content in page to edit

    Expected Result: to start editing title or text content

    Actual Result: JS error in console

    Also I've listed my version numbers in the original post, you mentioned "latest" but my version numbers match the latest on the theme pages on your site

  • Dean Taylor

    The steps to reproduce the issue are basically:
    - enter upfront edit mode from homepage
    - click the "New Post" button from upfront panel on left
    - wait for new post page to load
    - click / double click content in page to edit

    Expected Result: to start editing title or text content

    Actual Result: JS error in console

    Also I've listed my version numbers in the original post, you mentioned "latest" but my version numbers match the latest on the theme pages on your site

  • Vinod Dalvi

    Hi Dean,

    Thank you for sharing the detailed instructions to reproduce the issue.

    I could reproduce the issue on my test site by following the instructions that you have shared. I get different JavaScript error messages as shown in the attached screenshot than that you have shared.

    I have notified the theme developer about this issue so that it can be fixed.

    The issue will be fixed ASAP.

    Thanks,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.