Unable to edit Upfront theme info

Cannot change Upfront custom theme info. Adding theme image, but Builder doesn't save the modification.

  • Adam Czajczyk

    Hello @admin1989!

    I hope you're well today and thank you for you question.

    I have checked your site and I can see the error there. I tried to replicate that on my own test setups but even though I tried in many different ways, I wasn't able to. I check with Upfront starter themes as well as custom themes (that I have just created for the test and that I already had on the site), active and not active - on both Multisite and single site.

    Therefore, I think it's an issue specific either to you site or to the configuration of the server your site is hosted on. That being said, I reviewed the settings and I'd like to ask you to follow these steps:

    1. First, let's increase WordPress memory limit; while PHP on your setup allows around 256M of memory to be used for PHP scripts, your WP install is limiting that to 64M only which in case of a site like this is really a low amount.

    To raise that limit, please add following line to the "wp-config.php" file of your site, above the "/* That's all, stop editing! */ line:

    define('WP_MEMORY_LIMIT', '256M'):

    Once it's there, check again if the issue happens.

    2. If that didn't help, we'll need to look into WP debugging output. In that case please add 3 more lines to the "wp-config.php" file (also above the "/* That's all, stop editing! */ line):

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    Once they are there, try changing theme info and image a couple of times and then look for the file called "debug.log" inside "/wp-content" folder on your server. If it's there, download it, rename to "debug.txt" and attach to you response here so I could take a look at it.

    Also, please check if in a root folder of your WP install (the same where the "wp-config.php" file is) you can see any file of a name similar to "error_log" and if so, please share it with me here as well (you might need to rename it so it had a .txt extension as well).

    Hopefully, this will help us to diagnose the problem in order to solve it :slight_smile:

    Best regards,
    Adam

  • Angel

    Greetings Adam,

    Is the line you entered here:
    define('WP_MEMORY_LIMIT', '256M'):
    ends with ":" or an ";"

    I tried making the file changes and still same error. Sadly, I could not change the info. I also cannot find the debug.log in /wp-content no error_log either. here is what my wp-config.php code looks like:

    define('WP_MEMORY_LIMIT', '256M');
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);
    /* That's all, stop editing! Happy blogging. */

  • Predrag Dubajic

    Hi Angel,

    There's a typo in Adam's code it should be a semicolon after memory limit define, I will update his post to change this.

    About the issue you were having, we did some further tests on multiple installations and were able to replicate it, not sure why it's not happening each time but we have reported it to our developers so they can investigate it further.

    Thank you for bringing this up to our attention!

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.