Unable to enable caching in Hummingbird

I have made several attempts to enable caching, but have been unsuccessful. I have added the proper mod_expire code to my .htaccess file (i think) but have no results. Can you please assist?

  • Rupok
    • Support Ninja

    Hi Patricia,

    So sorry for the inconvenience you are having and thanks for confirming that .htaccess code is not working for you. Can you please try the other suggestion shown in your Hummingbird Browser Caching section? I'm quoting from there:

    If .htaccess does not work, and you have access to vhosts.conf or httpd.conf try this:
    
    # Look for your site in the file and find the line that starts with <Directory> - add the code above into that section and save the file.
    # Reload Apache.

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let us know how these goes. If nothing above resolves your issue, can you please talk to your host to check if "mod_expires" is enabled on your server? Please let us know what they say about this.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin
    • Support Wizard

    Hi Patricia,

    Hope you are doing good today. :slight_smile:

    I checked your website, and I could notice you have disabled the Hummingbird plugin, so I'm not able to check it. Could I enable the plugin, and test this further? Please do specify your host on which the current website is running, so that we could have a better idea about this issue. If you are looking to troubleshoot this further, could you please send us your credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: http://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Patricia
    • WPMU DEV Initiate

    Nithin,
    I had to momentarily disable the plugin b/c activating a portion of it removed some formatting from my entire site. I am conducting a full site backup and then I will enable the plugin and provide you with login credentials. Thank you.

  • Nithin
    • Support Wizard

    Hi Patricia,

    Hope you are doing good today. :slight_smile:

    Thank you for sending in the credentials, could you please send us your websites FTP credentials as mentioned above, so that I could give a closer look at your configuration.

    You can send us the FTP credentials the same way as you have sent the WP dashboard login creds, as mentioned above:
    https://premium.wpmudev.org/forums/topic/unable-to-enable-caching-in-hummingbird#post-1193318

    Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Patricia,

    Hope you are doing good today. :slight_smile:

    Thank you for providing FTP access, the issue was with the following .htaccess rule from the security plugin:

    # REQUEST METHODS FILTERED
    # If you want to allow HEAD Requests use BPS Custom Code and copy
    # this entire REQUEST METHODS FILTERED section of code to this BPS Custom Code
    # text box: CUSTOM CODE REQUEST METHODS FILTERED.
    # See the CUSTOM CODE REQUEST METHODS FILTERED help text for additional steps.
    RewriteCond %{REQUEST_METHOD} ^(TRACE|DELETE|TRACK|DEBUG) [NC]
    RewriteRule ^(.*)$ - [F]
    RewriteCond %{REQUEST_METHOD} ^(HEAD) [NC]
    RewriteRule ^(.*)$ /wp-content/plugins/bulletproof-security/405.php [L]

    If you aren't making use of this rule, you can either delete/comment it. The above rules filters the head, and Hummingbird uses the HEAD method to get the headers from CSS, JS, and Images so that browser caching works.

    As a workaround, I have enabled the browser caching, and then added the above rules back to your .htaccess file, so that the browser cache works fine with the above rules.

    Please do note, if you disable browser caching, you'll have to repeat the above steps, in order to activate it, due to the conflict in the above rules.

    I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.