unable to get the mapping / multi domains to work

Please edit your /home/content/51/11791451/html/wp-config.php and move the line define( 'SUNRISE', 'on' ); above the last require_once() in that file or make sure you updated sunrise.php.

Hi Guys,

Been at this for days now and still cant get the hang of it. Please help! I have searched through many of your boards but yet I am still getting issues. I have a dedicated IP 188.121.55.15 .

I have WPMU and multi domains plugged in.

Regards,

Lee

  • Tyler Postle
    • CGO

    Hey Lee,

    I would be happy to help you with this!

    I notice that your installation is a subdirectory multisite and not a subdomain multisite. Multi-Domains plugin is only meant to work with subdomain installations.

    Are you just wanting to give your sub-sites their own top level domain? If this in the case, then just our domain mapping plugin would do the trick :slight_smile:

    I notice you are already using WordPress MU Domain Mapping from the WordPress.com plugin repository, this would also get your desired result; however, I have not used that one yet.

    Let me know if you have further questions on this one!

    Cheers,
    Tyler

    PS. Welcome to the WPMU Dev community!

  • Lee
    • New Recruit

    Hey Tyler,

    Thanks for responding and for the welcome. I have changed my subdomain to TRUE in the wp.config file so that it accepts.

    I created a new site called ma.helloleadgeneration.com and created an A record in my dns setting. However this is still not working.

    I also added two new domains in (marketingcreations.net / hellomarketingautomation.com ) within the multi-domains settings and (set the a records as *...) and they are still showing as unavailable.

  • Tyler Postle
    • CGO

    Hey Lee,

    Changing from subdirectory to subdomain can be a bit tricky. In fact, while installing WordPress multisite they tell you that it cannot be changed; however, it is possible. I've linked a couple helpful articles below:

    http://wordpress.org/support/topic/from-subdirectories-to-subdomains-how-to-change-wpmu-after-the-mu-install

    and

    http://edesign-pro.com/how-to-change-a-wordpress-blog-url-from-a-subdirectory-to-a-subdomain/

    If at all possible, I would do a fresh install. You can export all your content so you don't lose that then do the fresh install of WordPress and re-upload it. Or you can use our snapshot plugin to snapshot everything first: https://premium.wpmudev.org/project/snapshot/

    Save the snapshot to your computer and then upload it on the new install.

    Once we have your subdomains working correctly we'll tackle the multi domain issue :slight_smile:

    Let me know if you have any further questions!

    Cheers,
    Tyler

  • Lee
    • New Recruit

    Hey Tyler,

    I decided to completely uninstall and start a brand new network setup with the domains feature enable. I also created two new subdomain addresses and entered ab.helloleadgeneration.com and ma.helloleadgeneration.com and now I am getting 404 and 403 errors? When I went into the file manager, ma and ab folders have been created but are empty.

    Regards,

    Lee

  • Tyler Postle
    • CGO

    Hey Lee,

    Would you mind copy and pasting your .htaccess file in here? Problems like this can occur if the .htaccess isn't correct.

    Also, do you have a wildcard subdomain setup? Make sure it is pointed to the folder your WordPress installation is in.

    Keep us updated on the situation :slight_smile: We'll continue to help you troubleshoot the issues.

    Cheers,
    Tyler

    PS. Posting a screenshot of your wildcard subdomain setup could also help if you're still not sure.

    If all that is good and you're still having an issue then do you mind

  • Lee
    • New Recruit

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    That is my .htaccess

  • Pavel Petrov
    • WPMU DEV Initiate

    Hello Lee,

    Hope you're feeling good today!

    I'm sorry to hear about your problem!

    Two posts above you mentioned that the domains ma.helloleadgeneration.com and ab.helloleadgeneration.com have empty folders in the file manager.

    That means that those domains are pointed to those empty folders instead of your WordPress folder. If you want WordPress to be able to handle the requests to those domains they should actually be pointed to its folder.

    By the folder structure I assume you're using cPanel, this link should explain how to do that http://kb.site5.com/control/cpanel/cpanel-how-to-point-2-domains-to-the-same-folder/

    Let me know if that solution works for you!

    Take care,
    Pavel

  • Lee
    • New Recruit

    Hi Pavel,

    Thanks for the info. I have managed to get the multi-site up and running and logging into the dashboard of the new site.

    So I have set about setting up the multi-domain option of the site - I have installed but I am currently getting "Please copy the content of sunrise.php into /home/content/51/11791451/html/wp-content/sunrise.php and uncomment the SUNRISE setting in the /home/content/51/11791451/html/wp-content/wp-config.php file."

    I have put the sunrise.php within wp content and also put the line define( 'SUNRISE', 'on' ); above Thats all stop editing.

    Any ideas?

  • Tyler Postle
    • CGO

    Hey Lee,

    Thanks for your patience on this! Would you mind granting support access to your site via the dashboard WPMU DEV > Support > Support Access > Grant Access. and also sending your FTP access info privately through our contact form?

    Send in:

    Mark subject to my attn: ATTN: Tyler Postle
    Include link to this thread
    include link to your website
    include FTP host/user/password info

    Be sure to select "I have a different question" from the contact form topics. This will ensure that it gets to me :slight_smile:

    Once I receive the FTP info then I can ensure that everything is correct in the files.

    Have a great day!

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.