Unable to install Monitor

I am unable to activate Monitor. I am having the same problem reported in other threads:
"It appears that your home_url setting is trying to redirect to another domain. This often happens when you are forcing https but haven't updated your site setting for that. Please verify that the home_url option of your WP install is correct, then click refresh updates in the Dashboard plugin."

The entire site works fine in https and all attempts to access any page with http are forced to https as it should. Even my host (SiteGround) knows that the site is https.

Things I have tried already - none solved the problem:

1. I added define('FORCE_SSL_ADMIN', true); to wp-config.php even though it wasn't needed... made no difference.

2. I checked the options database to confirm both siteurl and home are correct including https://

3. Inside Edit Site, Siteurl and Home on the Settings tab both display correctly including https but Site Address on the Info tab shows http. I traced through this and believe this is a display issue inside esc_url() which is called from line 167 in network\site-info.php - I even temporarily edited to force https there and it caused the Site Address to display correctly but Monitor still returns the same failure when attempting to activate (I saw another fix someone posted but a fix in site-info.php would only affect this page whereas my attempt in esc_url() would apply to everything that calls the function).

4. I tried forcing WP_HOME and WP_SITEURL in wp-config.php even though the above steps seem to confirm this is not necessary... didn't help.

Other ideas? I am early in the process of setting up my site and am eager to resolve before investing more into the setup in case it is indicative of a bigger problem. At this point I have spent way too much time on it and appreciate any suggestions.

Thanks,
Steve