Unable to install Snapshot pro

While attempting to activate snapshot pro, I get:
"Fatal error: Call to undefined function spl_autoload_register() in .../wp-content/plugins/snapshot/snapshot.php on line 87..."

I've read up in the forums and seen that this was allegedly addressed before, but it is still occurring with the latest version of the plug-in installed via the WPMUDEV dashboard.

  • Nithin
    • Support Wizard

    Hi Boaz Arad,

    Hope you are doing good today. :slight_smile:

    Could you please switch to a default theme, and disable all the plugins, then enable snapshot, and check whether you are still getting the same error.

    If the above didn't resolve, please delete the plugin, and re-install, and check whether it helps.

    Please let us know how that goes, so that we could give a closer look. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Boaz Arad
    • Flash Drive

    Hi Nithin,
    Sadly the website in question resides on a rather finicky production sever.
    I was trying to install snapshot in order to easily replicate the site to my staging server.

    Since disabling themes and plugins on the production server is not an option, I'll have to transfer the site manually and continue work offline - where I strongly suspect that the plug-in will work.

    That said, assuming it is not a plugin/theme conflict, what would be your first guess as to the problems source?

    Moving the site with SnapShot would save me quite a bit of hassle...

  • Boaz Arad
    • Flash Drive

    Well, turns out the clowns in our IT dept. DOWNGRADED their PHP version to 5.2 without notification!

    I'll let you know if I have any trouble after I've convinced them to update to a version of PHP written during the last century :joy:

    Thanks for your help!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.