Unable to map new domains after upgrade to 3.1 of Domain Mapping plugin

I’m trying to map a new site I created on my multisite since upgrading to version 3.1 of the plugin but I’m not having any luck. I previously was able to map domains but after the upgrade I noticed that the domains I had previously mapped no longer appeared in the list (under Tools -> Domain Mapping). I thought that was strange especially since the domains still actually did work. I added them again just to be safe and didn’t think anything of it.

However, now when I try to add any new sites (or even a new domain to an existing site) that wasn’t in the list before the upgrade, it doesn’t seem to work. I even tried deleting the plugin and reinstalled it but no luck with that either. I have tried with more than one site and more than one domain and no luck.

Is there a bug or something else I maybe missing?

  • Barry
    • DEV MAN’s Mascot

    Can you upgrade to 3.1.1 and visit the Network Admin -> Settings -> Domain Mapping page and see if it reports any issues with the table existing / or not.

    Also check that the table name is the one you were expecting in the database (if you can, double check what domain mapping tables you have in there as you may have somehow switched from compatibility mode to the standard table names).

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.