Unable to retrieve meta data using meta analyzer tool

When using meta detection tools like http://analyzer.metatags.org/ or https://smallseotools.com/meta-tags-analyzer/, data can’t be retrieved. I attempted to disable Defender but still no luck.

  • Predrag Dubajic
    • Support

    Hi David,

    I tried running couple more tools for meta tags but they were also failing, so then I also checked your site availability with tools like https://www.uptrends.com/tools/uptime which had around dozen failed results and https://geopeeker.com/ which was unable to ping your site from any location.

    It seems that this is something related to your server and your hosting provider should be able to give you further details on what’s blocking those tools after checking server logs.

    Best regards,

    Predrag

  • David
    • The Incredible Code Injector

    Hi.

    I reached out to Blue Host support by phone. They initially do not see an issue in the error logs: https://www.develop4u.com/

    I ran geopeeker and my results were normal: https://www.screencast.com/t/uIu13u3ieaH

    Run from Tempe, Arizona, USA

    I ran uptrends from Los Angeles, CA and these were my results: https://www.screencast.com/t/FMjJITnJaBxS

    Note: my server was under an abusive bot attack last month. I reinforced the server using CP hulk on the WHM. But the ticket is not related to downtime. It’s in regards specifically to the inability for my metatags to be seen and indexed.

    Examples:

    https://www.screencast.com/t/2H0NR2BA

    https://www.screencast.com/t/raiTKje62

    Presently my SEO is invisible: https://www.screencast.com/t/BpAkfvhIvH

    Note: system restoring back to a 07-01-19 copy did not resolve the issue.

    Note: renaming the .htaccessfile did not resolve the issue.

  • David
    • The Incredible Code Injector

    Follow-up.

    There appears to be a conflict between the SSL certificate and the Analytics appearing.

    Note: Bluehost today deleted and reissued an auto ssl certificate.

    This was then integrated into the SItelock dashboard but the problem persists.

    NOTE: if I resolve the url for develop4u.com to http under the WordPress general settings AND turn off the SSL WordPress Plugins (I tried Really Simple SSL and WordPress HTTPS), Logout, then login to my dashboard and then run an analytics scan for the http version of my domain…my meta tags are visible:

    Screenshot: https://www.screencast.com/t/7bQpK3f7FAez

    http://analyzer.metatags.org/ search for http://www.develop4u.com/

    If I keep these settings and search for https://www.develop4u.com/

    My tags do not appear in the results.

    Screenshots: https://www.screencast.com/t/W39j3AW8k0B

    NOTE: if I resolve the url for develop4u.com to https under the WordPress general settings AND turn on or off the SSL WordPress Plugins Logout, then login to my dashboard and then run an analytics scan for the http or https version of my domain…the analytics scan fails to find my analytics:

    Scan for https url with https set under general settings: https://www.screencast.com/t/jih5MDmWS6WJ

    Scan for http url with https set under general settings: https://www.screencast.com/t/8A1o0oMcTnBV

    Presently the ONLY WAY to see my analytics is to resolve my site to http under general settings and only search for an http url.

    NOTE: this problem did not exist 4-6-8 weeks ago. I have had my site resolved to https with the Really Simple SSL plugin installed for years without issue. This is a recent issue.

    Note: Presently I have my site set to https under general settings and the Really Simple SSL set to on and my analytics are invisible. Defender is presently off.

  • Adam Czajczyk
    • Support Gorilla

    Hello David

    I hope you're well today!

    I think these meta-analytics tools still cannot access the site and the problem seems to be SSL certificate. Those tools seem to be a bit "too dumb" to report why they cannot get results but when I try our own WP Checkup and then simply to fetch the site with curl, I'm getting consistent and a bit more "elaborate" error message.

    In both cases it says that there's an error fetching site with an SSL certificate error. When checked in browser, the certificate seems fine at first but it's not. Take a look here please:

    https://www.ssllabs.com/ssltest/analyze.html?d=www.develop4u.com

    Apparently, according to this test the server's certificate chain is incomplete. Now, all the "analyzer" services must first be able to fetch the site's source code and they would use CURL or similar tool for this so that would result in an issue similar to the one showed on the screenshot attached above (coming from the onlinecurl.com service). So, they actually can't fully fetch site and as a result they can't detect meta tags.

    Taking that into account, I'd suggest getting in touch with the host again, asking them to help with proper certificate generation/installation. I can see that the certificate seems to be Let's Encrypt and that should be just fine if it was working fine so it's possible that it just has to be regenerated or your host must do some tweak in server configuration.

    Best regards,

    Adam

  • David
    • The Incredible Code Injector

    Thank you for your assistance on this issue. I believe, with your input Bluehost was FINALLY able to see the light…work with Sitelock to resolve the issue:

    (Couldn’t be happier with you guys)

    This is their message to me:

    Hello David,

    Thank you for contacting support. I sincerely apologize for the delay and the inconvenience this issue has caused. We were able to check the account and was able to replicate the issue with the Meta-tags.

    The issue was as you stated, where the SSL chain for the http://www.develop4u.com domain was missing from SiteLocks end. This was due to Sitelock having the Certificate and Key but not the CA Bundle. We were able to partner with SiteLock to get this updated for the account.

    The SSL is now showing installed, with SSL Labs giving the SSL an “A” ranking.

    User-added image

    https://www.ssllabs.com/ssltest/analyze.html?d=www.develop4u.com

    We were able to run the domain through Metatags site and is now able to read the site’s information.

    User-added image

    We ask that you recheck this once more from your end. Thank you for the opportunity to assist you today. Please let us know if you have any further questions.

    Thank you,

    Mel

  • Adam Czajczyk
    • Support Gorilla

    Hi David

    Thank you for your response!

    It seems it’s fine now, indeed :slight_smile: I checked SSL, tested site with CURL and tried those meta analyzers and all are now working without problems. I think I can confirm then that missing SSL chain was the issue and that your host managed to solve that :slight_smile:

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.