Unable to see GLOBAL SITE TAGS

Hello Support,

I am trying to display global site tags on my homepage.

I have installed the following plugins;

Post indexer

Global site tags

Global site tage widget

I can see post indexer working, as there is plenty of statistics

However, I can’t seem to get global site tags to display on my site. I have also tried the widget, and I receive the message where the widget is on my homepage “There are no tags to display”, yet I know there are.

I have tried switching to the default 2016 theme, and still not able to display the global site tags.

This is a WP Multi-site, and as far as I can see everything has been setup correctly.

Any help on how to resolve this would be great.

Many thanks for your help and support in advance.

Regards,

Kriss

  • Milan
    • WordPress Wizard

    Hello @nicholastea,

    I hope you are well today and thanks for asking us. :slight_smile:

    To display tags with Global Tag Widget you need to first index all of your pots and I can see that that operation is in queue already. Please wait till indexing operation gets finished and then check again.

    Cheers,

    Milan

  • Adam Czajczyk
    • Support Gorilla

    Hello Kriss!

    I checked your site and I can see that it’s not displaying global tags although posts are indexed. Just note though: in “Post Indexer” settings (“Global settings”:wink: you’ve got “post, page, users, categories, tags” defined as “Default post types”. There’s no need to do this as while indexing posts Post Indexer should take tags into the account. Furthermore, there’s no such thing as “tags”, “users” and “categories” post types in WordPress. I removed those definitions as they are not necessary there.

    Then, I reviews your site’s Post Indexer and also sub-sites settings and then tried to re-build index one more time, no luck though. That said, could you please access your site’s database via “phpMyAdmin” and make sure that these tables are there:

    – “_site_posts”

    – “_term_counts”

    Let me know please!

    Best regards,

    Adam

  • LDI IT
    • Site Builder

    Hi Adam,

    Thank you for your help.

    It looks like those two tables are not in the database. – Not sure why….

    Can I go ahead and just create those tables? Is there anything specific that needs to be setup for these tables?

    Any reason why the plugin wouldn’t add these tables? I can see other plugins have added additional tables in the past.

    Again, thank you for your help and support.

  • Adam Czajczyk
    • Support Gorilla

    Hello Kriss and thank you for your replay!

    I’ve attached a .zip file to this post. Please download it and extract it to your local storage. This is a set of SQL commands to create missing tables however before you execute them please make sure that your site’s WP db prefix matches the one in that code.

    By default the prefix is “wp_” so the table names would be like “wp_site_posts” etc. Please edit the “post-indexer.sql” file with “clean text” editor if necessary and make sure that you replaced all four occurrences of “wp_” prefix with your site’s current prefix.

    If you’re using “wp_” prefix for database tables there’s no need to change it. You can execute the code by either importing it to your DB via phpMyAdmin or via “SQL” tab of phpMyAdmin.

    Please make a full backup of your database first just in case anything went wrong!

    That said, could you please give it a try and once the tables are added, run “Rebuild index” for “Post Indexer” once again and see if it helps!

    Best regards,

    Adam

  • LDI IT
    • Site Builder

    Hi Adam,

    Thanks for this.

    I have imported the file into the database, and the tables have been created.

    I have ran the “Rebuild” and can see data being pulled through, however still no ‘Global Site Tags’.

    I can see the the rebuild is still in process, but the sites it has processed should have tags displayed, right?

    Again, thanks for your help.

  • LDI IT
    • Site Builder

    Hi Predrag,

    I have enable “Allow search engines to index” on the main site and all sub-sites, then rebuild the index, and still not able to see Global Tags.

    Anything else I can do?

    I have also given access through the WPMU Dashboard, for you to gain access for you to see if there is anything you can do on my site to get this working.

    Many thanks.

  • Predrag Dubajic
    • Support

    Hi Kriss,

    Apologies for the long overdue on this thread.

    I had another look at your site and it’s really strange that this is happening to you, I tried installing Global Posts Widget plugin on your site and the widget was showing your posts so the Indexer is working properly but for some strange reason your tags are still not being loaded.

    Could you provide us with cPanel login so we can further investigate this?

    You can send us your details using our contact form https://premium.wpmudev.org/contact/ and the template below:

    IMPORTANT: Make sure you select “I have a different question” for your topic so it doesn’t go back to forums – this and the subject line ensure that it gets assigned to me.

    Subject: “Attn: Predrag Dubajic

    – WordPress admin username

    – WordPress admin password

    – Login url

    – cPanel credentials (host/username/password)

    – Link back to this thread for reference

    – Any other relevant urls

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Kriss,

    Thanks for sending in those details, I had a look at you setup and everything seems in place and I must say I’m out of ideas here, I would need to forward this to our developers to have a look at and see what could be causing this.

    Thank you for your patience with this.

    Best regards,

    Predrag

  • LEE
    • New Recruit

    Hi Milan,

    The message I received from our IT guys was that the “itlaoda” user which you have has “sudo” access so you had the rights to do what you need to do. If that is not true please let me know.

    Thank you again for your help

    Lee

  • Panos
    • SLS

    Hello LEE ,

    Thank you for sending your credentials!

    It looks like Post Indexer plugin didn’t create “network_terms” table properly so I had to add it manually on your site and that should do it.

    We are looking into this so it doesn’t happen in future

    Could you please confirm if the tags are working as expected on your side?

    Thanks!

    Kind regards,

    Panos

  • Milan
    • WordPress Wizard

    Hello Kriss

    Hope you are well today and thanks for confirming. :slight_smile:

    Now when in future you face any similar issue, please do consider opening new thread for that. It will help us to keep issues separate to members though it seems similar. It also helps to go us granular and avoid any confusion for member who looks for issue. :slight_smile:

    Enjoy WPMU DEV.

    Cheers,

    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.