Unable to select categories while creating new classified ads from the front end.

When posting classifieds from the front end, I see the categories allocated to classifieds and the checkboxes besides them but cannot not check the boxes.
Looking at the html shows that the checkboxes are set to disabled. What gives? I'd really appreciate a proper and quick solution to this issue. This classified plugin has been giving me too many bugs. :slight_frown:

  • Patrick

    Hiya @chefouvi

    Sorry to hear you're having difficulty with this plugin :slight_frown:

    In order to be able to assign a category to a classified ad, the user role must have the "Edit Classifieds" capability.

    You can edit the user capabilities under "Classifieds" > "Settings" > "Capabilities". From the dropdown, select the role you wish to modify, and be sure the "Edit Classifieds" box is checked.

    Hope this helps! And thanks for being a member :slight_smile:

  • chefouvi

    Hi Patrick,
    Thank you for your prompt reply. Yes the capabilities were already properly set and triple checked. I am allowing all subscribers to post, delete and edit their own Ads.
    I currently implemented a work around via jquery forcing all the check boxes to be enabled. That fixes the issue but it is only a patch. If it was a permission issue, the jquery fix should not fix the problem as users should receive a permission error after checking a category and trying to post their ads.

    Here is what I did so far to troubleshoot the problem. I disabled all plugins except buddypress core, custompress built-in and classifieds, reverted to default theme to rule out everything from my theme. Same issue. Thanks again

  • Patrick

    Hi again @chefouvi

    Unfortunately, I'm unable to reproduce this issue on a test site (unless I actually remove the permissions for the user role).

    I disabled all plugins except buddypress core, custompress built-in and classifieds, reverted to default theme to rule out everything from my theme. Same issue.

    Excellent job of troubleshooting!

    The results you report would tend to indicate that the cause of the issue lies either with your BP install, or that of the Classifieds plugin.

    Let me see if I can get the plugin developer in here to provide some insight. This may take a bit longer than a normal ticket though. Hang on...

  • Arnold

    The only thing that would disable just the Category and tags input would be the "assign_terms" capabilities on the Custom Taxonomies. In Classifieds these are set automatically "assign_terms" => "edit_classifieds". This may have been damaged or the user doesn't have edit_classifieds capability.

    You can try this. Go to CustomPress and delete the two classified taxonomies. Then deactivate and reactivate the plugin. This will recreate them wih the default settings. See what that does.

    If that doesn't fix it send me an admin login to arnold at incsub dot com.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.