Unable to setup SMTP with Enewsletter

I am using enewsletter and unable to setup the SMTP settings. When testing the connection it shows:

Member is using office365 for SMTP

This is the error: Failed to send test email! - Please check your outgoing email settings and server config to see if selected ports are open.

  • James Morris
    • WordPress Enthusiast

    Hello tiffany,

    In order to help you better with your issue, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • James Morris
    • WordPress Enthusiast

    Hello tiffany,

    Checking your site's configuration and comparing it to the screenshot of your Office365 settings, I see you are using STARTTLS on Office365 for SMTP, but you had eNewsletter configured to use SSL. I attempted to use TLS, but this is not working as well. Can you please alter your Office365 settings to where you can use either SSL or TLS settings? If this is not possible, can you attempt to use either the PHP Mail or WP Mail functions instead?

    Best regards,

    James Morris

  • tiffany
    • New Recruit

    it did work, but does that still allow for cron?

    and if so, what are the right settings for cron if i want it to go out like once every 90 seconds ish? does the 50 per hour / 1ce and hour cover that? i get confused with the wording on "start cron every hour and then the however many per run - if that means it starts trying to send 50 every minute?

  • James Morris
    • WordPress Enthusiast

    Hello tiffany,

    I hope you are well today. I apologize for the delay in replying.

    it did work, but does that still allow for cron?

    Yes.

    RE: Cron. I would set that to no more frequent than every 5 minutes. Otherwise you risk getting flagged by your host. 10min would probably be better.

    I'm not sure what you're meaning about the link in the header? Where are you wanting to add this?

    Best regards,

    James Morris

  • Lindeni Mahlalela
    • Recruit

    Hello tiffanny,

    I hope you are doing great today. As I was going through some old threads I have noticed that this one is still open and we haven't had a response from you since the last questions from my colleague James.

    Would you please confirm if you still need help with this or you have it resolved in other ways. If you still need help, please clarify by answering the questions that James asked and then grant support access to your website so we can have a closer look. Please let us know if you still need help and we will be happy to help you in any way possible.

    I hope to hear back from you. Have a nice day.

    Cheers,
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.