Unable to take backup

I’m trying to take managed backups through Snapshot and unable to do it.

  • Nithin
    • Support Wizard

    Hi Multimedia Pastorale,

    I could notice there are many updraft backups and other big files which could have caused the Backup to not process, so I have excluded such files, and folders in the Snapshot plugin side, under Snapshot > Settings page.

    Also added the following rules:

    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_IGNORE_SYMLINKS', true);

    In the wp-config.php file but I’m afraid still the issue exists with backup not able to complete. Could notice there are folders in the root directory which isn’t part of the default WordPress core file, ie folders like /administrator, /img, /immagini, /sign are these folders useful?

    Also tried by excluding the above folder to see how the backup goes but it doesn’t seem to help much. The Managed Backup always ends up with the following error:

    GATEWAY TIMEOUT

    I’m escalating the issue further to our SLS(Second Level Support) team to see what else could be done to help get this sorted. Please do note that SLS works on complex issues, and have a slow response time will get back to you once we get further feedback asap.

    Kind Regards,

    Nithin

  • Multimedia Pastorale
    • WPMU DEV Initiate

    This is email received today from WordPress system:

    WordPress 5.2 ha una funzionalità integrata che rileva quando un plugin o un tema provoca un errore irreversibile sul tuo sito e ti avvisa con questa email automatica.

    In questo caso, WordPress ha incontrato un errore con uno dei tuoi plugin, [Snapshot] Sync backup files, reject large files.

    Per prima cosa, vai al tuo sito web (http://www.diocesipiacenzabobbio.org/) e controlla se ci sono problemi visibili. Successivamente, vai nella pagina in cui è stato rilevato l’errore (http://www.diocesipiacenzabobbio.org/wp-admin/admin.php?page=snapshot_pro_snapshots) e verifica se c’è qualche problema visibile.

    Contatta il tuo host per richiedere assistenza per una investigazione più approfondita di questo problema.

    Se il tuo sito appare danneggiato e non puoi accedere normalmente alla tua bacheca, WordPress ora ha una speciale “modalità di ripristino”. Ciò ti consente di accedere in modo sicuro alla tua bacheca per controllare cosa non va..

    https://www.diocesipiacenzabobbio.org/wp-login.php?action=enter_recovery_mode&rm_token=cWTn13JOmmCJlR7VIuvfby&rm_key=MHA5h9H99YdqUAxdb90ueU

    Per mantenere il tuo sito sicuro, questo link scadrà tra 1 giorno. Non preoccuparti di questo: ti verrà inviato un nuovo link se l’errore si ripresenta dopo la scadenza.

    Dettagli dell’errore

    ====================

    Un errore di E_PARSE è stato causato nella linea 1206 del file /home/diocesip/public_html/wp-content/plugins/snapshot-sync-backup/snapshot-sync-backup.php. Messaggio di errore: syntax error, unexpected end of file

  • Tho Bui
    • Staff

    Hello Multimedia Pastorale,

    Apologize for the delay, I have excluded some files, and folders in the Snapshot plugin side, under Snapshot > Settings page. Also added the following rules:

    define("SNAPSHOT_IGNORE_SYMLINKS", true);
    define("SNAPSHOT_FORCE_ZIP_LIBRARY", "pclzip");//pclzip || ziparchive

    In the wp-config.php file, and I see it’s working fine now. So I think it relates to the maximum execution time, it’s so too low. In that case, I suggest you contact your hosting provider and ask them to increase the maximum execution time so you can remove some folders from the setting.

    One issue, when I enabled the PclZip lib, while trying to create the backup file I got some errors with some files name have unicode character, like this /uploads/2017/06/….-EssenzialitaÌ%80.pdf, uploads/…della-carità1.jpg. This issue will break the backup process, so I excluded these files too. I also discuss this with our dev, we can’t replicate this case on our site. So I will move it to our dev closer check on this issue. And this issue does not happen if we use ziparchive lib instead but it got timeout error on my test. So while waiting for the response from our dev, after you increased the maximum execution time I suggest you tried with zip archive lib by remove/comment this line define(“SNAPSHOT_FORCE_ZIP_LIBRARY”, “pclzip”:wink:.

    Kind Regards,

    Tho Bui

  • Adam Czajczyk
    • Support Gorilla

    Hello Multimedia Pastorale

    I dont’ understand: is the problem solved?

    It’s not quite solved. Let me try to explain it a bit more.

    Tho Bui found out that changing the way the backup archive is created, makes the backup process work. If plugin is switched to use “pclzip” library instead of default “ziparchive” – it does work with some exceptions.

    “Ziparchive” and “pclzip” are just two different “methods” (server related) of creating .zip file. The first one is default as its available on pretty much all the servers. But it is slower and consumes more server resources.

    The “pclzip” – if it is available, and apparently it is on your server, should be faster and consuming less resources.

    When testing the site Tho found that with “ziparchive” method backup is not being processed fine and fails while with “pclzip” the process itself goes fine. That’s why he switched it by adding this line to the “wp-config.php” file:

    define("SNAPSHOT_FORCE_ZIP_LIBRARY", "pclzip");

    If you remove this line from “wp-config.php” file, plugin will switch back to “ziparchive” method which is failing.

    However, Tho suggests that the “ziparchive” method is failing because of PHP configuration so what he asked is that you get in touch with your hosting provider and asked them to increase the value of the PHP “max_execution_time” option. It should be at least over 150 but I’d suggest seting it to value of e.g. 300 seconds if possible.

    If they’ll do this for you, remove that

    define("SNAPSHOT_FORCE_ZIP_LIBRARY", "pclzip");

    line from “wp-config.php” file and check if backup is then working or if it still fails. If it does, let us know.

    Also, this is suggested because while when switched to “pclzip” method, Managed Backup works, it unfortunately breaks on some specific files that include some special national characters. The only way to make it complete is to exclude those files from backup. That’s why

    – Tho suggested trying to increase max_execution_time and switching back to ziparchive method (as explained above)

    – and he also asked our developers to investigate further why those special characters are breaking backup if its created using “pclzip” method.

    Best regards,

    Adam

  • Multimedia Pastorale
    • WPMU DEV Initiate

    “increase the value of the PHP “max_execution_time” option. It should be at least over 150 but I’d suggest seting it to value of e.g. 300 seconds if possible”. DONE. On shared servers it is not possible to increase the max_execution_time to more than 120 seconds, but we have added a 300 second dynamic timeout rule, to avoid this limit and allow the plugin to work correctly.

    About switch to ziparchive, DONE. Please verify yourself if corrected.

    Now i start backup. If it work…

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.