Unable to take backups

I'm having issues backing up. I'm getting a time error when trying to backup. I've went into my cp to try and increase the size but when I've tried to back up again I'm now getting an error (502) with CloudFlare.
Web server is returning an unknown error:
There is an issue between CloudFlare's cache and your origin web server. CloudFlare monitors for these errors and automatically investigates the cause. To help support the investigation, you can pull the corresponding error log from your web server and submit it our support team.

  • Dimitris

    Hey there Rebecca,

    hope you're doing good today! :slight_smile:

    First of all, I'd like to inform you that I've tried to perform a snapshot in a test installation of mine using Cloudflare and the integration provided by HummingBird -> Browser Caching admin page and I had no issues with that.

    I then accessed your webpage and noticed in WPMUDEV -> Support -> System Info [button] -> PHP [tab] that max_execution_time is successfully increased to 300.

    I then went ahead and created a new snapshot with success as you can see for yourself here
    YOURDOMAIN.com.au/wp-admin/admin.php?page=snapshot_pro_snapshots&snapshot-action=view&item=1500571255

    Prior to that, I've just purged cache from HummingBird -> Browser Caching, can't tell if this was necessary though, as I hadn't had to do so in my test installation.

    Let us know if further assistance is required here!
    Warm regards,
    Dimitris

  • Dimitris

    Hey there Rebecca,

    hope you're doing good today! :slight_smile:

    I was able to see this issue with Managed Backups, my bad, I thought that you were mentioning Snapshots, I'm really sorry for that!

    I can see that you're using multiple cache coming from Bluehost, Cloudflare, W3TC and HummingBird (browser cache). As all these techniques may conflict each other, I'd like you to keep each cache technique, for example Page Cache or Browser Cache, activated only in one service. So, if you enable browser caching in HummingBird, disable it in Bluehost and W3TC.
    After doing so, go ahead and try to run a Managed Backup once more.

    Finally, I can see that there're some troubleshooting steps considering this specific error code coming from Cloudflare.
    https://support.cloudflare.com/hc/en-us/articles/200171936-Error-520-Web-server-is-returning-an-unknown-error
    These are requiring some SSH access, so you may have to contact Bluehost to check this for you.

    Warm regards,
    Dimitris

  • Rebecca

    Hi,
    Thanks for the info, Bluehost have fixed this issue at their end and i can now do a Managed Backup. I have tried to turn off the Cache techniques so im running just one over all of my plugins but im not 100% sure if ive done it right. Are you able to test that again to let me know - or point me to somewhere that i can check. Im still learning all of this.

    Also, in my speed tests im failing miserably due to the large amounts of images i have - the latest test i did had my page loading at 45 seconds and it was due to the media file. Can i do any more within your plugin to optimise my images so they load faster?

    Many thanks
    Rebecca

  • Predrag Dubajic

    Hi Rebecca,

    It looks like browser caching is configured properly now so you should be good to go with that.

    As for the loading times, I'm afraid that there's not much Hummingbird can do here, there are 14 sliders loaded in there and that requires a lot of resources even though the images are properly optimized.

    What does have a large impact as well is the time to first byte (TTFB) which is a time needed to get response from your server, and in my tested this took up to 11 seconds, which is a long time.
    This is somewhat improved by caching plugins (server side caching not browser caching) but it mostly depends on server itself and it's best getting in touch with your hosting provider about this.

    There's also an issue with bg_general.png image, this image is used on your homepage but it doesn't exist on your server and it extends your loading time for almost 5 seconds.
    This image is trying to be loaded in CSS for your header cart so try removing that CSS or check why the file is missing and add it if needed.

    Hope this helps :slight_smile:

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.