Unable to update and WPMU plugins: Could not find update source

When trying to update WPMU plugins via either Wordpress Plugin updater, or WPMU updater, it fails. For WPMU: Could not find update source is shown in red at the top of the screen.

Had the problem with a slightly old version of WPMU DEV plugin, and updated it manually. Now it's not on the list of plugins requiring updates, but it didn't fix the issue.

I see others with this problem at various times, but didn't see any solutions.

Support access was granted.

Thanks,
Tim

  • Vaughan

    Hi Tim,

    Hope you're well?

    It looks to be a conflict with another plugin you use.

    I disabled allplugins except wpmudev dashboard & it worked perfectly fine.

    I can't say which plugin though, for that you would need to deactivate 1 at a time & test each time until the issue disappears.

    Or deactivate all plugins, and keep trying 1 at a time, testing each time, until the issue returns, then you will know which plugin is conflicting.

    You can follow the flowchart on the following page.

    https://premium.wpmudev.org/manuals/getting-support/

    Hope this helps

  • mindcue

    Hi Vaughn,

    I'm going to sound harsh in this response. I do appreciate your checking into it, and yes, I know disabling plugins is rule one with conflicts. I get that. And I'd be fine with a response that said that--well, not really, it'd be annoying. I was looking for better clues as to what sort of plugin or conflict there could be. Thought there might have been a known issue I missed in my searches.

    But...

    This is a relatively highly traveled site (not uncommon to have >40 people online at once).

    I wish youd not turned everything off... At least not without being able to put things back *exactly* as they were.

    Supercache is very important on this site and it was disabled when I just checked.

    Other plugins lost their license keys. I have no idea what else might be broken or configuration messed up... So now I have to spend a bunch of time checking every one.

    Exactly how did you "disable all plugins" for this stuff to happen? Curious for my own reference--it actually could come in handy sometimes.

    I'm fine that it's a conflict, but all of the plugins we used are important, thought there may be settings on some to avoid the problem.

    Sorry, but while I really do appreciate the quick response, I'm frustrated at how it broke a few things. I know I granted permission. Just didn't expect it to cause stuff to not work afterward.

    I'll setup a clone test site and work from there.

    Mini rant over. I hope you don't take it personally, and can simply file it away for reference on other tickets. Fair?

  • Vaughan

    Hi,

    No offense taken, I simply de-activated allplugins via the plugins page. then checked.
    I then re-activated all the plugins again except the 4 that were already de-activated.

    Apologies, I hadn't checked about API keys on some plugins, I can see how that will have caused issues.

    I'm not entirely sure on which plugins may cause it, but my guess would be any plugins that offer remote management or updates, such as update plugins from other premium plugin/themes companies that have similar type of dashboard plugins to handle their updates, as they can conflict with the remote requests. So I would start with those to begin with.

    Hope this helps, and again apologies for my mis-judgement when i tried to debug.

  • mindcue

    Hi Vaugnen,

    Glad you aren't taking my response wrong.

    I've got some of the test site going, but the issues so far aren't showing up. I need to go and install and mess with plugins to see which ones are missing.

    I might go the disable one at a time route on the live site, very carefully--it just isn't at all ideal.

    Any thoughts on the sort of things that would cause this specific message? I was thinking security plugins, but it could be simpler... Any issues with https sites? Cloudflare?

    Thanks,
    Tim

  • mindcue

    I'm back trying to sort this out.

    We do use Cloudflare but use page rules to disable optimization and caching on wp-admin pages. We don't use their plugin, just the service.

    We have a test version of the site that does not have this issue (same domain, separate directory).

    Someone else with this problem mentioned that installing a WPMU plugin works, and this is also the case for us. We can install a new plugin, just can't update.

    While it was noted in one of your responses that you disable all other plugins and it worked or you, but when I try to disable each plugin briefly, and then test and update, it still fails. Seems unlikely that it would be multiple plugins causing trouble.

    I also added the WPMU api debug variable (recommended in another thread) and the other WP debug variables to the wp-config, and did not get any WPMU information logged at all--just some warnings from other plugins.

    Since this is a fairly busy live site, it's important that tests be brief and relatively safe with testing.

    Is there some way to better trace the code and figure out what's causing the error? I started to look at the code, but didn't get too far. When I searched for the message string it didn't come up (possibly my error).

    Seems that it would be a clue that updates fail, but new plugin installs (via WPMU updater) work.

    I'm fine editing code for the WPMU Updater plugin to try and find the cause if there's a spot for some debugging code.

    Hope you have some ideas, or could take a look again.

    Thanks,
    Tim

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.