Unable to upgrade to 3.1

I'm using multidb 3.0.5 and I can't upgrade to wordpress 3.1 currently. It keeps error'ing out with "Warning! Problem updating . Your server may not be able to connect to sites running on it. Error message: A valid URL was not provided. "
I can't help but think this is also related to the funky characters in my posts question.
This is a pain in the ass, I didn't use any 3rd party editors or anything. I used the multdb import, I don't have any other plugins live. Why do I have characters in my posts and why is my upgrade to 3.1 failing out saying it can't find the site name? I can get through 80 sites with no problem and then it fails.
Please help, I just want to get this out of the way so I can focus my time on other improvements (like getting more of the plugins I'm paying for from you guys installed)