Unable to use payment gateway for public

I have added CoursePress Pro pulgin in my website, but the enroll/buy now is not visible for everyone. It is only visible for registered user only. I want to make visible and available for public, not only for registered users. Help me out to solve this problem. Thank you.

  • Kasia Swiderska
    • Support nomad

    Hello gauravgurbaxani,

    I can see that you are using the previous version - can you update to the latest version of the CoursePress?
    What option did you choose in " Who can Enroll in this course "? Did you activated MarketPress also if you want to use payment gateway?
    I also see that you still use old MarketPress - can you update it to the latest version? - as both plugins as prepared to work together in updated versions.

    Kind regards,
    Kasia

  • gauravgurbaxani
    • Flash Drive

    I have installed both the plugins, I have tried to update both of them but the site gone down and this massage appeared- Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home2/*username*/public_html/xyz.net/xyz/wp-content/plugins/marketpress/includes/common/class-mp-product.php on line 369
    I have updated by both the ways, without deleting the old files, and also after deactivating and the deleting the older version and then installed it again. Both the time same error.

  • Rupok
    • Support Ninja

    Hi gauravgurbaxani

    I hope you are having a wonderful day.

    Can you please check the PHP version of your server? I'm assuming it's still using PHP 5.2. Can you please update your PHP in your server and check again?

    I believe it will fix the issue.

    Have a nice day. Cheers!
    Rupok

  • gauravgurbaxani
    • Flash Drive

    I have updated each and every thing - Php (from 5.2 to 5.4) from server also with pulgins, but still enroll button is not visible for public. I am getting only 4 options -
    1- Manually added only
    2- Registered User
    3- Registered User with a pass code
    4- Registered User who completed the prerequisite course

  • Kasia Swiderska
    • Support nomad

    Hi gauravgurbaxani,

    I still see that you have not updated MarketPress and the CoursePress - upgrading PHP to version 5.4 will fix error with new MarketPress T_PAAMAYIM_NEKUDOTAYIM - if for ANY reason this will not fix this error, please use those files https://dl.dropboxusercontent.com/u/152848/includes.zip and replace old ones in marketpress directory (archive does include corresponding folders).
    With both plugins updated you should be able to sell your courses.

    Please do backup of your site before doing any changes.

    If all of this will not help, then please enable support access to your site. You can grant support access via WPMU DEV > Support > Support Access > Grant Access.

    Kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello gauravgurbaxani,

    Can you switch to the default CoursePress theme? I've checked your site and you use Theme that already have courses implemented - and it is using the same slugs for theme. This is causing conflicts.

    When you try to buy course directly from MarketPress it adds them to the cart - because there is no slug name conflict.

    Kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.