Undefined lgoin error and google calendar not synching

Undefined error showing up when attempting to login on the frontend after update, and google calendar not synching. My clients cannot book an appointment without being logged in. It is really affecting my business and causing me to lose clients. I am really tired of having the same issue over and over again with this plugin.

  • Milan

    Hello WebTesa

    Hope you are well today and thanks for asking us. :slight_smile:

    My clients cannot book an appointment without being logged in.

    There is one settings in Appointments+'s settings page through which you can set Login required to book an appointment or not. :slight_smile: Please select "No" for the dropdown Appointments > Settings > Accessibility Settings > Login Required

    Undefined error showing up when attempting to login on the frontend after update

    Can you tell me where you have placed Login shortcode or something like that on frontend ? I can't find any Login Widget or Login page on front end which can help me to login to your site. Am I missing something here. ? Or you are referring front end login as login done by wp-login.php file ? Please advice.

    Google calendar not synching

    As you can see in this screenshot, there are logs which states that there is issue with Google Calendar project setup on your end. Also I saw this error of "not loading google calendar" on Google Calendar Integration Settings page. These stats clear suggest us to create new project by the instruction given or check existing one for misconfiguration.

    Let me know how it goes.
    Cheers,
    Milan

  • WebTesa

    Yes I am aware that I can make it so that my clients don't have to login to book an appointment. I am also aware that if I require them to login the plugin should still work. I am also aware that I have followed all instructions to get my google calendar to sync and it is still not working. I'm not quite sure what happened when you all completely recoded the google calendar sync it has not worked for me ever since, even after following all the instructions given.

    By the way. The appointment page of my website is where clients login to make an appointment.

  • Milan

    Hello again WebTesa ,

    Hope you are doing well and thanks for clarifying about this.

    I thought you are asking me to disable login, I was not knowing you were referring that your users are not able to login to site.

    I've just tried to enable login from Appointment+ and got the same undefined error. So I've flagged our developer for this. Hopefully they will start their work to solve this very soon. I will also ask our developer to provide some temporary fix on this.

    Meantime can you update your Appointment+ plugin to its latest release. ? I can see that there is one update notification for Appointment+ plugin. :slight_smile:

    Kind Regards,
    Milan

  • Milan

    Hello WebTesa

    I got to know that your issue with "undefined" has been solved on this thread
    https://premium.wpmudev.org/forums/topic/appointments-plus-showing-undefined-error-when-attempting-to-login#post-1069384

    Can you please confirm ?

    Google calendar not syncing

    I can see that you are still using an older version of plugin, so its my humble request that you update your plugin to latest release and is there any reason you are not updating your plugin ?

    One possible reason I can guess is that you are thinking it will loose changes given by my colleague panoskatws . So to be on safe side, let me tag panoskatws here to explain you what were those changes so that you can apply those safely after updating plugin. :slight_smile:

    Thanks for being with us. :slight_smile:
    Cheers,
    Milan

  • Panos

    Hello WebTesa ,

    Hope you are doing well today :slight_smile:

    I would like to say that I totally agree with Milan . I have seen that in the changelog file of version 1.8 there is a fix for Google Calendar as you can see in the screen shot attached:

    Since this should probably fix your problem I would suggest to consider upgrading to v1.8 which has several other fixes to :slight_smile:

    You can find a patched version of 1.8 here: https://www.dropbox.com/s/lbyoujk4od56pvf/appointments.zip?dl=0 so you don't have the login troubles. So instead of updating plugin from WPMU DEV you can simply download the patched version and replace existing plugin files.

    As I have mentioned on the other thread about this issue, I strongly recommend to keep a backup before doing any theme/plugin updates. You can use our Snapshot plugin for taking a quick backup!

    It would also be a good practise to have a staging/testing site (even better if it is on the same server) where you can first check updates of themes and plugins and if there are no issues you can make the updates on your production site.

    Thank you for your valuable feedback on this!

    Kind regards,
    Panos

  • Adam Czajczyk

    Hello WebTesa,

    I hope you're well today and don't mind me jumping into this conversation!

    I'd like to ask you to go reset Google Calendar integration config (in Appointments+ settings) once again and then go through the procedure once again. You do not need to create a new app this time (although you may if this would be easier for you) and instead you may use existing APP. The important part is to double check that there's no spaces/blanks at before and after client id and secret and access code while you're pasting them into Appointments+ GCalc integration settings.

    I'm suggesting this because it turns out that copying this data from Google Developers Console adds unnecessary spaces (blank characters) and these sometimes cause similar issues.

    Let me know if this helped, please!
    Best regards,
    Adam

  • Adam Czajczyk

    Hello WebTesa,

    I admit that's getting more complex. I'd like to take a lot more closer look at your site and also Google app settings. Could you please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password)
    -- cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Also please go to your Google developers console, select a project that you created for GCal integration and then
    - click on menu icon (three horizontal bars) on the left of "Google APIs" logo
    - select "Permissions" menu item
    - add this e-mail adamwpmudev+webtesa@gmail.com to the project, selecting user role of "Owner"

    Please use our contact form here https://premium.wpmudev.org/contact/.
    Select "I have a different question" from the drop-down list.

    Please be sure to make a full backup of your entire site first!

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.