Under Home Page Settings for Blogs-MU

There is an option called, Your Network sub intro post text. When I use this field, the text shows on every page. I thought these options were only for the home page. I am using default template or full width template for the other pages and homepage template for the home page. How can I prevent this field from showing on all pages?

thanks