Unfortunately, we do not seem to have Upfront core installed on this site. We need that for the Upf

Hi,

I've just installed the Upfront builder plugin on a new site. When activated I get this message:

Unfortunately, we do not seem to have Upfront core installed on this site. We need that for the Upfront Builder plugin to work. Get it here.

But following the link takes me here:
https://premium.wpmudev.org/projects/category/themes/

What's it asking me to do?

Thanks in advance,
Dave