Ultimate Facebook: Ungrant extended permissions

I'm wondering if I can ungrant extended permission in order to start over. I tried de-activating the plugin and reactivating. I've also upgraded to the version 2.0.1 that Ve just pushed out.

When I click on Grant Extended Permissions a dialog box quickly opens, but I can't see anything but white, and within a second or two it closes itself. I suppose it's giving itself permission to post on my wall because that is the only option that I have under the Autopost to FB. I can only select my personal profile as the User, not the Page that I'm looking for.

Also, the sidebar widget gives the error 'No recent activity to display.'

  • 3SixtyEvolve
    • New Recruit

    Hi Pali Baacsi

    First of, thank you for being a member of our Community! And then, a very big thank you for the detailed posts and screenshots. This will definitely help us to narrow down what could be causing this.

    Before I ask for feedback from the Developer, I would just like to rule out any conflicts with other plugins. So please deactivate any other plugins that you're using with the Ultimate Facebook Plugin and see if the error still persist. Also, please let me know what theme you're using.

    I look forward to your feedback and getting this problem sorted for you.

    Have a good day!

    Gina

  • Vladislav
    • Dead Eye Dev

    Hello,

    There are a couple of possible issues here, so let's try to tackle them one by one. You can un-grant your extended permissions just like you would for any other Facebook app (say, a game): to do this, navigate to your Facebook profile page, log in and select "Privacy Settings" from the dropdown menu next to the "Home" menu item. On next page, click "Edit settings" next to the "Apps and Websites" item, then "Edit settings" button next to "Apps you use". You'll end up on the page with a list of all the apps you use, and there you can modify or completely remove any permissions you want.

    As for the extended permissions issue, can you please go to the "Advanced" tab of your App settings (on Facebook), and make sure that the "Deprecate offline access" migration is set to disabled? After this you will have to re-grant your permissions in the plugin settings one last time.

    As for the Activity feed widget issue, can you please toggle the "Do not use xfbml tag" checkbox at the bottom of your widget settings and see if that helps? Lastly, as for other issues you experienced, can you please take a look in your javascript console and see if there are any errors reported there?

  • Paul Barthmaier
    • Code Wrangler

    Well, I had tried everything above and was not having any love. Fortunately, it was Sunday and the Post Office was closed, so I wasn't able to go Postal on anyone. Leaving it alone for a while I just came back to it and started by trying to install Ult FB on another site using a different app with similar settings. While I wasn't able to get the new site up either, I did see that there should be a FB admin area on each subdomain which isn't the case on the network in question. I am only seeing Ult FB admin settings in the Network Admin area.

    Having said that,figuring I had little to lose, I changed the AppID and Secret from the original App Settings to the new one, clicked save, and then realized that that wouldn't work because the Apps had different domains associated with them. I switched back to the original information and was asked to Grant extended permissions, and Voila! It looks like it's working now!

    So on to the second network where Granting permissions seem to be just hanging.

    As for the original network in question, what should I make of the subdomans not having their own FB admin area, and therefore, do not have a location where an Error log can display?

  • 3SixtyEvolve
    • New Recruit

    @Pali Baacsi

    Glad you got the one sorted. As for the network in question, is the Ultimate Facebook Plugin network activated? If so the admin settings won't show on the sub-domains. If you network deactivate, you would be able to activate it per sub-domain and hence it would have their own Ultimate Facebook admin settings.

    Please let me know if this works.

    Have a good day :slight_smile:

    Gina

  • Paul Barthmaier
    • Code Wrangler

    Hi Gina and Ve,

    Sorry to report. I don't have this one completely sorted. The Activity Feed isn't working still. I saw that Comments were coming thru and mistakenly thought it was the Activity. I'm still getting nothing from the Activity widget. Attached is the settings that I have on the site.

  • Paul Barthmaier
    • Code Wrangler

    As for the FB settings on Network admin vs Admin panel, I'm glad to hear that on the site that I'm trying to get the Activity Stream working is correctly set up. I have another site that I'm playing with and it seems that there is an issue and it's probably related to the fact that I have installed WP-Netowrks, but I haven't tested this assumption. Here's what I'm seeing, though:

  • 3SixtyEvolve
    • New Recruit

    Hi @Pali Baacsi

    Hope you're well.

    Thank you for providing the link to your other thread as well. I have flagged the Developer for both instances and will check with him what feedback he can provide. Please bear with us. I know he is in the process of doing some important updates to certain plugins, but I can assure you we want to get this sorted for you.

    I will be in touch at the earliest.

    Have a good day!

    Gina

  • 3SixtyEvolve
    • New Recruit

    Hi @Pali Baacsi

    Hope you're well.

    Just a quick note to say we haven't forgotten about you. I'm waiting for feedback from the Developer, however, he is busy with an urgent assignment at the moment, so I apologize for the delay in getting back to you.

    I will follow up with the Developer again in a few days. In the meantime, if you did manage to solve the problem, please let me know.

    Thank you in advance for your patience. I will be in touch shortly.

    Have a good day!

    GinaB

  • aecnu
    • WP Unicorn

    Greetings Pali Baacsi,

    Just checking in to see where we are with this issue?

    In your original post you had mentioned wanting to start over with the install of this plugin to include "Unpermissioning" the Ultimate Facebook application.

    It is my opinion to accomplish this you would need to remove the plugin of course, delete the app on Facebook, and to remove all mention of Ultimate Facebook plugin from the database.

    Please advise where we are now and which of the above removal aspects you are having a problem with?

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Pali Baacsi,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Pali,

    The first thing is to please update your Ultimate Facebook to the newest version that was just released a few days ago.

    Then to revisit the Ultimate Facebook instructions and paying attention to every detail to make sure the settings are as they should be according to them. I do not mean to redo the entire things of course, just to confirm each and every setting that is called for in the instructions.

    Relative to the advanced developers page and the terms of service, this is for when you have a regular Facebook application i.e. games etc. that you need to create a terms of service for and a page.

    I do not think that it has anything to do with the activity stream. However, I do think that the activity stream or lack thereof may be related to the portion of the instructions under the Grant Extended Permissions Tab heading.

    Please advise after putting the above instructions and settings under the microscope how we are doing with the activity stream issue :slight_smile:

    Cheers, Joe

  • 3SixtyEvolve
    • New Recruit

    Hi Pali

    I haven't heard back from you in a while so I will go ahead and resolve this question/post, however, please don't hesitate to reopen it if you still require additional feedback from our Support Team. Just select the 'Mark as Not Resolved (re-open)' box below the post area (otherwise we might miss your new post).

    Have a good day and all the best!

    Gina

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.