Unit Not Appearing for Students

I've tried everything. I cannot figure out what is wrong. My Course Introduction Unit in the "Final Mold Remediation Certification Course" is not appearing for students. I can't figure out why. It looks like it is published to me. Please help!!!

I gave support ticket access already...to whomever can help. I appreciate any input. Thank you in advance.

  • James Morris

    Hello Savana,

    I hope you are well today. Thank you for having Support Staff Login enabled so I can look into this issue for you. I have been able to confirm the issue you are seeing on your site.

    First, I see you are running an older version of CoursePress. The latest version is 2.0.4 and has had numerous bug fixes. First, would you please update to the latest version and retest to see if this issue is still present?

    If it is, could you please run a plugin conflict test as outlined in the following article? This will eliminate the possibility of a conflict with another plugin. https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If that does not lead to a solution, could you please enable WP_DEBUG and provide us with the output of your debug.log file?

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you've visited the pages that are causing you problems, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, open that file with a text editor like notepad (Windows), GEdit (Linux), or TextEdit (Mac). You can then paste the contents of that file at http://pastebin.com/ and share the URL of the pasted output with us so we can examine it further.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris

  • James Morris

    Hello Savana,

    Thank you for providing that information. There's definitely an issue with your CoursePress install causing Fatal PHP Errors.

    In order to help you better with your issue, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • James Morris

    Hello Savana,

    Thank you for sending that information in.

    I've been performing some advanced debugging on your site. It seems the issue is related to user roles (capabilities). When a student is below the Administrator user role, they cannot access the 1st unit. However, once they are made and Administrator, the unit becomes available.

    I've reported this ticket to our SLS Team (code experts) in order to get their valuable feedback on this issue. An update will be posted as soon as technically possible.

    Best regards,

    James Morris

  • Panos

    Hi Savana ,

    By default CoursePress has benn designed to display Units that contain modules that accept input from student (eg a text box, multiple choice etc).

    In latest version of CP, a new option has been added providing the ability to display units without modules. As I notice that your first unit has only output modules ( intro etc ) I suppose this can be it. Could try enabling this option for your courses and see if the units are now visible?

    To set this option, go to CoursePress > Courses, click on the course you want, in the course page click on "Step 2 - Course Details" and scroll to the "Course Structure" area. It should have an option "Show units without modules" as in following screenshot:

    Check that checkbox and save, then have a look if this unit is now visible and let us know how it goes :slight_smile:

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.