Units disappeared after UPDATE (1.2.6.7)

Hey guys,

please take a look on this problem!!! all of the units of my courses just disappeared after updating CoursePress PRO to the 1.2.6.7 version !

Philipe

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Philipe,

    Hope you are doing good today :slight_smile:

    I am sorry to hear its not working for you after upgrade. However, to make sure its not a bug in new version I upgraded on my own test site and still can see the units on my course page.

    It appears there is some thing on your website that is conflicting with CoursePress plugin. Please run a quick plugin conflict test as illustrated in our getting support manual and let me know the results.
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Philipe
    • The Incredible Code Injector

    hello there!!

    I deactivated all of the plugins but Coursepress and still its not working, guys I need urgency on this cause I'm about to market this website, can't have these kind of problem.
    Every time I see a new update from coursepress I get scared!! it's when I know I'm one click away of getting possible problems!! =/ I already granted support access so you can take a look !!

    Thanks for you help !

    Philipe

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Philipe,

    Hope you are doing good today :slight_smile:

    Its appears to be a temporary issue that solved itself after switching to TwentyFifteen theme and then back to CoursePress theme.

    Hope that helps! If you still need assistance, please don't hesitate to ask.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Philipe,

    Hope you are doing good today :slight_smile:

    You are welcome and I am sorry for any inconvenience. WordPress is know for conflicts, we are always here to help :slight_smile:

    Yes, I am marking this as resolved and checking the other thread.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Philipe
    • The Incredible Code Injector

    Hey Sajid,

    the course - vocabulario-expressoes-versao-gratis/units/ has no units, I'm pretty sure I had everything set up, including the videos was working perfectly!! first I have the problem with all of the courses and now it's with this one ! any help?

    another question, where's the option to put FREE PREVIEW on paid courses?

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Philipe,

    Hope you are doing good today :slight_smile:

    I am sorry for delay here, I guess we both posted the message almost on same time and your last message got missed.

    I accessed your site again via support staff access and can see you have 0 units in Verbos + Vocabulário + Expressões (Versão grátis) course, so its not a CoursePress issue.

    I have checked the video on your other course and its playing just fine for me as seen in attached screenshot. So that's seems to be issue with cache on your browser, please clear the browser cache or try on different browser. I checked on this course.
    http://courses.nativeportuguese.co/courses/expressoes-do-portugues/units/1-fiquei-sabendo-de-algo/page/1/

    To enable free preview you have to enable course structure under Step 2 - Course Description on edit screen (see second screenshot).

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Philipe
    • The Incredible Code Injector

    thanks for your reply,

    the problem here is that I had the 9 units ready to publish and they disappeared after I upgrade coursepress to the latest version, it happened the same with the other lessons as I mentioned at first but by switching between the Twenty seven theme and coursepress pro theme it got to work again, but the course that´s not showing the units yet is the (http://courses.nativeportuguese.co/wp-admin/admin.php?page=course_details&course_id=2255)

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Philipe,

    Hope you are doing good today :slight_smile:

    I am sorry for any inconvenience, I can see there are no units at all in the database so that's why they are not showing on frontend. It appears they got deleted after upgrade :slight_frown:

    Right now the only way to get them back is by restoring the database where it was before upgrading CoursePress plugin. Otherwise you have to do that again, I am sorry its not ideal but its only way to do that if they got deleted. That is why its recommended to keep backup of your site first before installing/updating any WordPress plugin even before updating WordPress itself.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Philipe,

    Hope you are doing good today :slight_smile:

    Yes, you can find it in wp_posts table with course post type. If you are familiar with phpMyadmin and MySQL import/export then look in this table where post type equals to "unit" and in wp_posts_meta table look for course_id key and value equals to the ID of your course, you can find the ID in URL while editing the course. Then you have to create new course and must add the course_id meta key to associate units with course.

    The other way is setup a dev/staging site with old database and import/export it with WordPress import tools.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Philipe,

    Hope you are doing good today :slight_smile:

    I am sorry for confusion, its not post parent its course_id meta key in wp_posts_meta table.

    Also, you can setup dev/staging site with old database and then copy paste the content from old site to new site manually.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.