Unwanted strip slashes in text widgets

I know people say this all of the time, but this really just started happening out of the blue.
Every time I try and save simple HTML code in my text widgets, it keeps adding backslashes and F'ing up the code!
WTF?

It was fine the last 3 days, why is this happening and is this something in Wordpress?
Why would they put that there?

Anyone know how to make it stop?

  • eborg9

    Here is the link
    http://nyblogs.net
    I upgraded to the latest version of Buddypress this morning and that didn't cause any problems (other than the normal deleting all user blogs like the upgrade always does) , so I didn't associate it with that until now.

    I am also noticing that the site won't load properly unless I do a hard refresh. I read somewhere on the forum that your themes are not yet compatible with Buddypress. Could this be the source of my trouble?

    Edited: Sorry, yes it's just a regular text widget in "Header 2". I'm scared to touch the others, and I'm using the blogs.mu theme

    Re-Edited:
    I noticed that it's not just my Text Widget, it's in my image widgets as well...everywhere where there is a link or plural apostrophe...it's surrounding them with strip slashes so all of my links are directing to this:

    http ://nyblogs. net/\\\"http://nyblogs.net/members/\\\"

    So...I guess that would mean that it's something in my .htaccess file?

  • Tammie

    @eborg: no our themes 'are' compatible with BuddyPress and 'should' be compatible with 1.2.4 it just may be some bug or something that was fixed in 1.2.4 could impact - it's only been out a few hours but we will have updates soon. I suggest maybe you look at your install as there could be other issues. Perhaps try using widgets with the default BuddyPress theme see what happens then. You need to eliminate the factors here. But to confirm our themes if listed as BuddyPress compatible all have a number of what version also besides them on the theme page - best check that out each time.

    To note is a .something release is usually a more 'fix' release rather than breaks themes or other elements - however it may have in a fix something that effects a theme.

  • eborg9

    I have tried to eliminate every possibility and have come to the conclusion ( maybe falsely) that it is not the theme, or a plug in.
    somewhere, somehow, something is affecting my links. Everything that was created prior to this morning is fine...anything that was edited since then, is all jacked up and I cannot find a fix that doesn't involve some extensive hacking...and I just don't think that hacking the core or any other files is the way to go since I didn't hack anything to make it start doing it.

    The only variable that I can place a finger on is upgrading BP.

    What causes strip slashes to just appear? Is it some kind of code variable? It has to be a command somewhere, but where? And what activated it?

    Something else I see is that since the upgrade, it doesn't recognize me as having any blogs. The blogs are still there, and I can still access the backend, but when I look at my admin bar and the drop down that says" Blogs" it doesn't show that I have any.

    Edited: Removed last thing. It has nothing to do with it.

  • eborg9

    2 hours later (hour 8 now of messing with this) and now all I can find are my own questions in Google. There was one article that claimed a fix, that everyone else referred to, but of course it was 2 years old and it didn't work for me.

    so far i have:

    Loaded the database back up
    Repaired the database
    Removed all plug ins, including Buddypress
    Changed to Default theme
    Removed all additions to htaccess
    Taken my MU installation down to bare bones so that it is just the installation only.

    and still, the mysterious strip slashes continue to appear on their own when I'm trying to make a simple link.
    And it's not just with the text widgets, it's adding strip slashes to everything all over the site, posts, pages. EVERYTHING. I can't touch anything or risk it becoming completely non-functional.

    Even more amazing is that there are just questions about it and none of the threads end in a solution...so what did all of these people do?

  • eborg9

    I fixed it.
    I still don't know why it was happening, but I decided to start re-installing files to insure that my installation was tight and I started with the wp-includes folder and that seemed to fix the problem..no more stipslashes.

    Kind of anti climatic and a pisser at the same time.
    I should just remember that "When in doubt, reinstall"

    Thank God I never considered all the solutions out there that involved hacking the core, re building the database and rewriting code.

  • Aphrodite

    Please could you be more explicit on what you've done I am still in the [censored] with taht [censored] apostrophe issue, even if I have done all solutions found on the several support forum included the official one.

    I have no magic quotes, php 5.3.1, even hardcoded the database at leat for the title in the mails and frontpage title but there are stil some \ everywhere, whatever the theme is.

    I reinstall all, for 5 minutes no trouble and suddenly (with no new plugin or so) the \ appear.

    I even put

    remove_filter ('category_description', 'wptexturize');
    remove_filter ('list_cats', 'wptexturize');
    remove_filter ('comment_author', 'wptexturize');
    remove_filter ('comment_text', 'wptexturize');
    remove_filter ('the_title', 'wptexturize');
    remove_filter ('the_content', 'wptexturize');
    remove_filter ('the_excerpt', 'wptexturize');

    in the thme functions.php , but i I put that in WP funtions.php I get an error and nothing works.
    How a so simple issue can have benn forgotten by devloppers ?????????? As a single stripslash could solve the problem ? :slight_frown:

  • Aphrodite

    sorry I dont understand what you mean by "overwrite all your core files"

    its a fresh install... It works for few minutes, and then the problem occures with any theme.

    many peaople experiment that, i have read at lest 380 topics on that subject since days, and all the possible solutions have been experiemented. as many, still have the problem.

    sure its server side but what exactly ! no idea. mbstrings ? off ! magic quotes ? off !

    I even hardcoded the mysql encoding (utf8 generic c) in wp-config :slight_frown:

    and always au nice #39 inserted in the database...

    The crazy thing is that comes only in site title, sent mail subject and title, several headers in the theme but NOT in the texts or articles as shown with my edublog topic on that issue !

  • Aphrodite

    that occure at least with edublogs & nelo. corporate i will test it on a fresh install but since widgets dont work on it i dont use it at all. (but i love it !)

    I have business also installed on another site i'll look.

    But some plugins do that also i must do un new install, step by step and test it

    I do that tomorrow and i tell tou :slight_smile:

    But seriusly, shouldn't we wait a little and look with WP 3 ?

    I am not in emmergency, i can wait and learn learn learn during this time :slight_smile:

  • eborg9

    Most of the problems like this that I have encountered were because of my FTP program. Sounds strange, but my FTP program skips files. Even when I reinstall, it can sometimes skip the exact same file every time.

    You can get what appears to be a clean install and everything works just fine and still be missing a file or two and you will never know it, until WP needs that file, and then all hell breaks loose.

    So for me, yes, I used another FTP program, and re installed wp-includes and the problem went away.

    I had my host working on it all day and scoured forums and articles looking for a fix. I even did a database rollback to a time when it was working fine and it still didn't help.

    And since I didn't do any hard core file edits to make it start behaving like that, I refused to believe that hacking the files was the only way to fix it...there had to be something else. So for me it was wp-includes.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.