Unwanted stuff on my website pages after updating!

I have some unwanted links on my website pages and I'm not sure how to get rid of them. All I did was update my pages and my website is ruined. Please tell me how to fix it. Here's a link: http://www.tamaranataliemadden.com. I really need to fix this soon. Thank you in advance.

  • Lindeni Mahlalela

    Hello Tamara

    I hope you are doing great today. Thank you for contacting us regarding this issue.

    Could you please give us more information about the unwanted links on your website, where are they? Also please give us access to your site so we can have a closer look and see what went wrong. You can enable support access by following this guide.

    I am looking forward to your response and I hope we resolve this soon.

    Have a nice day.
    Mahlamusa

  • Tamara

    This stuff shows up on my website when I try to login. Now I can't login at all! The site looks fine online, but when I type in my login info, this is what I get. I can't do any editing at all!
    Warning: Invalid argument supplied for foreach() in /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php on line 391

    Warning: Invalid argument supplied for foreach() in /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php on line 439

    Warning: array_keys() expects parameter 1 to be array, null given in /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php on line 445

    Warning: Invalid argument supplied for foreach() in /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php on line 439

    Warning: array_keys() expects parameter 1 to be array, null given in /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php on line 445

    Warning: Cannot modify header information - headers already sent by (output started at /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php:391) in /home/arttist/public_html/admin22.php on line 414

    Warning: Cannot modify header information - headers already sent by (output started at /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php:391) in /home/arttist/public_html/admin22.php on line 426

    Warning: Cannot modify header information - headers already sent by (output started at /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php:391) in /home/arttist/public_html/wp-includes/pluggable.php on line 914

    Warning: Cannot modify header information - headers already sent by (output started at /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php:391) in /home/arttist/public_html/wp-includes/pluggable.php on line 915

    Warning: Cannot modify header information - headers already sent by (output started at /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php:391) in /home/arttist/public_html/wp-includes/pluggable.php on line 916

    Warning: Cannot modify header information - headers already sent by (output started at /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/class-mp-cart.php:391) in /home/arttist/public_html/wp-includes/pluggable.php on line 1210

  • Lindeni Mahlalela

    Hello Tamara

    I hope you are doing great today. Thank you for the feedback and I am sorry that you can't login to your site. I hope we resolve this soon.

    Could you please login to your website via FTP then in the document root, usually 'public_html' folder or wherever WordPress is installed, locate the file with the name 'wp-config.php' open it to edit then find the following line:

    define('WP_DEBUG', true);

    replace it with this:

    define('WP_DEBUG', false);
    define('WP_DEBUG_DISPLAY', false);

    This will change WordPress's debug mode to not output any errors to the browser. These unwanted stuff are debug warnings and you should not worry about but just do the edit above and they should go away.

    If you need me to check and do this fix for you then you may share your FTP details and enable support access so I can have a closer look. You may share login details via our secure contact form, in the form share type "Attn: Lindeni Mahlalela" in the subject field and then in the Message box include:

    - FTP login details (FTP Host, port, username and password)
    - WordPress login details if you did not enable support access (login url, username and password)
    - Link back to this thread for details

    Once I have access I will login and do further troubleshooting and report back to you what I found. I am looking forward to your response.

    Have a nice day.
    Mahlamusa

  • Andi

    Uff Tamara.
    I would suggest changing the hoster to be honest. If they still run PHP 5.4 what MySQL they are running? etc I guess they simply don't keep their system updated so I would recommend to change the hoster.
    Actually you should not change to 5.6 but to PHP 7.+ as this is what it is! we are meanwhile talking about PHP7 and WP 4.8 is running just perfect and fast with it.
    Anyway the setting to change your Maximum memory allocation is still the same in PHP 7 like it was in PHP 5.4 and even earlier. Have a look into your php.ini file if you can access that.

    Here it is described for a drupal site but it is the same for a wordpress site
    https://www.drupal.org/docs/7/managing-site-performance-and-scalability/changing-php-memory-limits

    The video is describing how to change it at Godaddy. so if you are there or using CPanel it might be the same. Each Panel looks different but they actually all do the same - they write and change the value in php.ini

    Kind regards
    Andi

  • Lindeni Mahlalela

    Hello Tamara

    I hope you are doing great today.

    PHP 5.4 is very old and it is advisable to change to PHP 5.6 for the latest security updates. I have seen the video you linked to above it seems to be specific to GoDaddy cPanel so it looks safe to follow, but here is how you should change the values in regular cPanel.

    Go to you cPanel account and go to the Softaware section, choose Multi PHP INI Editor (or similar depending on cPanel version):

    Then in the next page choose the domain:

    And finally modify the 'memory_limit' limit to a recommended 256M or at least 128M, you may also adjust the other limits like max_execution_time to at least 150 or a much higher value.

    [image pos="2"]

    If you prefer to use another method, you can open the File Manager and find a file called 'php.ini' or '.user.ini' and add the following lines and save:

    memory_limit = 258M
    max_execution_time = 150

    Alternatively you can find the file 'wp-config.php' in your root folder and then add or change the following lines:

    define('WP_MEMORY_LIMIT', '64M'); //for front end
    define('WP_MAX_MEMORY_LIMIT', '256M'); //for WordPress admin

    You can use any of these methods, they all do the same thing the difference is that if you use the method in the video, the first one above then it will end up writing the 'php.ini' or '.user.ini' outlined in the second method and these changes will apply to any script running in the domain. The last one will change only when WordPress is executing.

    I hope this helps.

    Have a nice day.
    Mahlamusa

  • Lindeni Mahlalela

    Hello Tamara

    Sorry the other screenshot was not uploaded. Here it is:

    Also Andi is correct about the latest PHP 7+ and WordPress 4.8 but I suggested you change to 5.6 because the latest may not be available on your host, you may change your host if you prefer to do so but in case you don't want to then upgrade to whatever your host has as the latest PHP Version. Thank you Andi for the suggestion, I also didn't notice you were responding, it seems we were both responding at the same time.

    Have a nice day.
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.