Update?

I don't understand what is being asked here, I try to edit in the Fixers theme and get an error that Upfront needs to be updates . . . I was of the understanding that those child themes should automatically install and update Upfront?

http://screencast-o-matic.com/watch/cDiOFHiC7E