Update broke all kinds of CSS

The update from 2.1.1 to 2.1.7 broke all kinds of custom CSS.

Please stop changing the element names between revisions.

  • dannyo
    • Site Builder, Child of Zeus

    Cole,

    Please advise what needs to change to fix the broken CSS:

    /* Fundraising customization */

    div.wdf_donate_button {
    text-align:center;
    }

    span.wdf_level_amount {
    text-align:center;
    }

    div.wdf_reward_item {
    text-align:center;
    }

    .widget_wdf_fundraisers_list {
    font-size:16px;
    border:0;
    background-color:transparent;
    }

  • dannyo
    • Site Builder, Child of Zeus

    Cole,

    I see that you changed wdf_donate_button to wdf_backer_button. That's really bogus that you changed things like this causing a bunch of broken CSS.

    I'll post a summary of my straightened out CSS (in its entirety) so that everyone can refer to it but, for the time being, I'm pretty pissed that things like that changed.

    Please post a complete list of all element name changes.

  • dannyo
    • Site Builder, Child of Zeus

    ** What is the correct element to apply CSS in order to affect the wdf_button?

    Its padding is too small (zero by default, apparently, or so I believe) and if in Firebug I cancel padding:0; for wdf_button a { it returns to a more appropriate size, but I can't seem to implement the change. I don't think I know exactly what element I need to call.

  • Timothy Bowers
    • Chief Pigeon

    Hey there.

    Thanks for sharing your concerns, whilst I can fully appreciate and understand them please don't swear in the forums. That would be much appreciated.

    As Cole has made these changes I'm not sure why but what I can do is ping him to this thread, so he can pop in to have a word regarding your issues.

    Take care.

  • Cole
    • The Incredible Code Injector

    Hey dannyo,

    Sorry about those changes. You are not the first to bring up the issue. It was a mistake on my part a while back and I completely understand the frustration.

    Now I think the element you are looking for is .wdf_backer_button

  • dannyo
    • Site Builder, Child of Zeus

    Thanks, Cole! I do see in a separate thread that a comparable problem has been reported as solved in your prerelease version. Based on seeing that post, I'm marking this thread as resolved.

    Timothy, I'm so sorry if my choice of words bothered you (or you believed it might bother others); it seems I still have a bit to learn -- I didn't realize until just checking that, apparently, it's considered a "bad word" in the UK. My apologies.

  • Timothy Bowers
    • Chief Pigeon

    Timothy, I'm so sorry if my choice of words bothered you (or you believed it might bother others); it seems I still have a bit to learn -- I didn't realize until just checking that, apparently, it's considered a "bad word" in the UK. My apologies.

    Its absolutely fine :slight_smile:

    It doesn't bother myself personally, but often people can be more sensitive as I'm sure you've come across before.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.