Update just the files for compability with new wordpress version

Hello, I have a last version of coursepress 1.3 because I modify the plugin to much and I need to change many files if I update the plugin, but I have the new version of wordpress and I want to know, which are the files than change just to fix the compability of wordpress? because if I update all the plugin I need to start to modified all again.