Update Notifications

Getting the follow errors after activating many plugins ...... Update Notifications is just one example.

WPMU 3.2.1
Update Notifications 2.1.3
Theme 20/10

Only plugins installed: AntiVirus, WP Security Scan, Custom Spam Pack, Anti-Splog (All current stable releases)

Any help is appreciated.

ERRORS

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/mysite/public_html/wp-includes/functions.php on line 3466

Notice: Undefined index: anti-splog/anti-splog.php in /home/mysite/public_html/wp-content/plugins/wpmudev-updates/update-notifications.php on line 359

Notice: Trying to get property of non-object in /home/mysite/public_html/wp-content/plugins/wpmudev-updates/update-notifications.php on line 359

Notice: Undefined index: page in /home/mysite/public_html/wp-content/plugins/wpmudev-updates/notifications.php on line 30