Update Notifications compatibility

Hi,
I'm new here and just started to install WPMUDEV plugins on a WP 3.0.1 multisite setup to find that Update Notifications (1.0.3) is not working (see: https://premium.wpmudev.org/forums/search.php?q=update+notification&s=Search+The+Forums+%C2%BB ).

Mine shows an empty list of plugins, even if some are correctly installed, the update now link of course goes to a 404 ( /wp-admin/wpmu-admin.php?page=wpmudev&action=update&updated=true&updatedmsg=Data+updated. ) because that file simply doesn't exist on WP 3.0.x, but on Update Notification project page it's declared as 100% compatible with WP 3.0.

I'm a bit worried: what's your policy for declaring plugin compatibility?

Alessandro